6.2.4 Packet Tracer – Configuración de EtherChannel Respuestas

Última actualización: octubre 14, 2021

6.2.4 Packet Tracer – Configuración de EtherChannel Respuestas (versión para el instructor)

6.2.4 Packet Tracer – Configure EtherChannel Español

Nota para el instructor: Los elementos con color de fuente rojo o resaltados en gris indican texto que aparece solo en la copia del instructor.

6.2.4 Packet Tracer - Configuración de EtherChannel Respuestas
6.2.4 Packet Tracer – Configuración de EtherChannel Respuestas

Objetivos

  • Parte 1. Configurar los parámetros básicos del switch
  • Parte 2. Configurar un EtherChannel con PAgP de Cisco
  • Parte 3. Configurar un EtherChannel LACP 802.3ad
  • Parte 4. Configurar un enlace EtherChannel redundante

Aspectos básicos

Acaban de instalarse tres switches. Hay enlaces redundantes entre los switches. En general, solo uno de estos enlaces puede utilizarse; de lo contrario, podría producirse un bucle de puente (loop). Sin embargo, con el uso de un solo enlace, se emplea solo la mitad del ancho de banda disponible. EtherChannel permite que hasta ocho enlaces redundantes se agrupen en un enlace lógico. En esta práctica de laboratorio, configurará el protocolo PAgP (Port Aggregation Protocol, protocolo de agregación de enlaces), un protocolo Cisco EtherChannel y el protocolo LACP (Link Aggregation Control Protocol, protocolo de control de agregación de enlaces), una versión de estándar abierto IEEE 802.3ad de EtherChannel.

Antes de comenzar la configuración, revise las Pautas y restricciones de configuración de EtherChannel que aparecen al final de esta actividad.

Tabla Port Channel

Channel Group (Grupo de canales) Puertos Protocolo
1 S1 F0/21. F0/22
S3 F0/21, F0/22
PAgP
2 S1 G0/1, G0/2
S2 G0/1, G0/2
LACP
3 S2 F0/23, F0/24
S3 F0/23, F0/24
Negotiated LACP

Instrucciones

Parte 1: Configuración de los parámetros básicos de un switch

a. Asigne a cada switch un nombre de host según el diagrama de topología.

b. Antes de comenzar la agregación de enlaces entre switches, compruebe la configuración existente de los puertos que conectan los switches para asegurarse de que los puertos se unirán correctamente a los EtherChannels. Los comandos que proporcionan información sobre el estado de los puertos del switch incluyen:

S1# show interfaces | include Ethernet
S1# show interface status 
S1# show interfaces trunk

c. Configure todos los puertos necesarios para EtherChannels como puertos troncales estáticos.

Nota: Si los puertos se configuran con DTP y usted no establece el modo de los puertos en enlace troncal, los enlaces no forman enlaces troncales y siguen siendo puertos de acceso. El modo predeterminado de un switch 2960 es dynamic auto y esta habillitado. DTP se puede desactivar en interfaces con el comando switchport nonegotiate.

Parte 2: Configurar un EtherChannel con PAgP de Cisco

Nota: Al configurar EtherChannels, se recomienda desactivar los puertos físicos que se van a agrupar en ambos dispositivos antes de configurarlos en grupos. De lo contrario, es posible que «EtherChannel Misconfig Guard» cambie el estado de estos puertos a err-disabled. Se pueden volver a habilitar los puertos y los port channels después de configurar EtherChannel.

Paso 1: Configure Port Channel 1

a. El primer EtherChannel creado para esta actividad agrega los puertos F0/22 y F0/21 entre el S1 y el S3. Configure los puertos entre los switches como puertos de enlace troncal.

b. Utilice el comando show interfaces trunk para asegurarse de que tiene un enlace troncal activo para esos dos enlaces, y que el Native VLAN sea el mismo.

S1# show interfaces trunk

Port Mode Encapsulation Status Native vlan
F0/21 on 802.1q trunking 1
F0/22 on 802.1q trunking 1
G0/1 on 802.1q trunking 1
G0/2 on 802.1q trunking 1

<output omitted>

c. En ambos switches, agregue los puertos F0/21 y F0/22 al Port Channel 1 con el comando channel-group 1 mode desirable . La opción mode desirable permite que el switch negocie activamente para formar un enlace de PAgP. Nota: Las interfaces deben apagarse antes de agregarlas al grupo de canales.

S1(config)# interface range f0/21 – 22
S1(config-if-range)# shutdown
S1(config-if-range)# channel-group 1 mode desirable
S1 (config-if-range) # no shutdown

S3(config)# interface range f0/21 - 22
S3(config-if-range)# shutdown
S3(config-if-range)# channel-group 1 mode desirable
S3 (config-if-range) #no shutdown

El mensaje «Creating a port-channel interface Port-channel 1″ debería aparecer en ambos switches cuando se configura el Port Channel. Esta designación de interfaz aparecerá como Po1 en la salida del comando.

d. Configure la interfaz lógica para que se convierta en un enlace troncal ingresando el comando interface port-channel seguido del numero de puerto lógico,y luego switchport mode trunk . Agregue esta configuración a ambos switches.

Nota para el instructor: Packet Tracer 7.2.1 y anteriores no califica el comando switchport mode trunk en las interfaces de Port Channel.

S1(config)# interface port-channel 1
S1(config-if)# switchport mode trunk

S3(config)# interface port-channel 1
S3(config-if)# switchport mode trunk
Paso 2: Verifique el estado del Port Channel 1

a. Emita el comando show etherchannel summary para verificar que EtherChannel funcione en ambos switches. Este comando muestra el tipo de EtherChannel, los puertos utilizados y el estado de estos. Se muestra el resultado del comando para S1.

S1# show etherchannel summary
Flags: D - down P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3 S - Layer2
        U - in use f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------
1 Po1(SU) PAgP F0/21(P) F0/22(P)

b. Si no aparece el EtherChannel, desactive las interfaces físicas en ambos extremos del EtherChannel y vuelva a activarlas Los comandos show interfaces trunk y show spanning-tree también deberian mostrar el Port Channel como un único enlace.

Parte 3: Configurar un EtherChannel LACP 802.3ad

Paso 1: Configure Port Channel 2.

a. En el año 2000 el IEEE lanzó 802.3ad, que es una versión de estándar abierto de EtherChannel. Se conoce comúnmente como LACP. Con los comandos anteriores, configure el enlace entre S1 y  S2, usando los puertos G0/1 y G0/2, como EtherChannel LACP. En  S1 debe usar un número de Port Channel diferente de 1, porque ya usó ese número en el paso anterior. Para configurar un canal de puertos como LACP, utilice el comando  channel-group2 mode active . El modo Active indica que el switch intenta negociar activamente ese enlace como LACP, en comparación con PAgP. La configuración del S1 se muestra a continuación.

S1(config)# interface range g0/1 - 2
S1(config-if-range)# shutdown
S1(config-if-range)# channel-group 2 mode active
S1 (config-if-range) #no shutdown
S1(config-if-range)# interface port-channel 2
S1(config-if)# switchport mode trunk

S2(config)# interface range g0/1 - 2
S2(config-if-range)# shutdown
S2(config-if-range)# channel-group 2 mode active
S2 (config-if-range) #no shutdown
S2(config-if-range)# interface port-channel 2
S2(config-if)# switchport mode trunk
Paso 2: Verifique el estado del Port Channel 2

Utilice los comandos show del paso 2 de la parte 1 para verificar el estado del Port Channel 2. Busque el protocolo que utiliza cada puerto.

S1# show etherchannel summary
Flags: D - down P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3 S - Layer2
        U - in use f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------------

1 Po1(SU) PAgP Fa0/21(P) Fa0/22(P)
2 Po2(SU) LACP Gig0/1(P) Gig0/2(P)

Parte 4: Configurar un enlace EtherChannel redundante

Paso 1: Configure el Port Channel 3

Existen varias maneras de introducir el comando channel-group número mode:

S2(config)# interface range f0/23 - 24
S2(config-if-range)# channel-group 3 mode ?
  active Enable LACP unconditionally
  auto Enable PAgP only if a PAgP device is detected
  desirable Enable PAgP unconditionally
  on Enable Etherchannel only
  passive Enable LACP only if a LACP device is detected

a. En el switch S2, agregue los puertos F0/23 y F0/24 al canal de puertos 3 con el comando channel-group 3 mode passive. La opción passive indica que desea que el switch utilice LACP solamente si se detecta otro dispositivo LACP. Configure el Port Channel 3 como interfaz de enlace troncal de forma estática.

S2(config)# interface range f0/23 - 24
S2(config-if-range)# shutdown
S2(config-if-range)# channel-group 3 mode passive
S2 (config-if-range) #no shutdown
S2(config-if-range)# interface port-channel 3
S2(config-if)# switchport mode trunk

b. En el switch S3, agregue los puertos F0/23 y F0/24 al Port Channel 3 con el comando channel-group 3 mode passive. La opción active indica que desea que el switch utilice LACP incondicionalmente. Configure el canal de puertos 3 de manera estática como interfaz de enlace troncal.

Paso 2: Verifique el estado del Port Channel 3

a. Utilice los comandos show del paso 2 de la parte 1 para verificar el estado del canal de puertos 3. Busque el protocolo que utiliza cada puerto.

S2# show etherchannel summary
<output omitted>
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------
2 Po2(SU) LACP Gig0/1(P) Gig0/2(P)
3 Po3(SU) LACP Fa0/23(P) Fa0/24(P)

b. La creación de vínculos EtherChannel no impide que STP detecte bucles de conmutación. Ver el estado de STP en los puertos activos en S1.

S1# show spanning-tree active
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID Priority 32769
             Address 0001.436E.8494
             Cost 9
             Port 27(Port-channel1)
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

  Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
             Address 000A.F313.2395
             Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
             Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1 Root FWD 9 128.27 Shr
Po2 Altn BLK 3 128.28 Shr

Port Channel 2 no funciona porque STP colocó algunos puertos en modo Blocking. Desafortunadamente, esos puertos eran los puertos Gigabit. En esta topología, puede restaurar estos puertos configurando S1 para que sea la raíz principal de la VLAN 1. También puede establecer la prioridad en 24576.

S1(config)# spanning-tree vlan 1 root primary

o

S1(config)# spanning-tree vlan 1 priority 24576

Es posible que tenga que esperar a que STP vuelva a calcular la topología de STP. Pulse el avance rápido si es necesario. Utilice el comando show spanning-tree active para comprobar que los puertos Gigabit están ahora en estado Forwarding.

Pautas y restricciones de la configuración de EtherChannel

EtherChannel tiene algunas pautas específicas que deben seguirse para evitar problemas de configuración.

1. Todas las interfaces Ethernet admiten EtherChannel hasta un máximo de ocho interfaces module, sin necesidad de que las interfaces estén en el mismo módulo de interfaz.

2. Todas las interfaces dentro de un EtherChannel deben funcionar a la misma velocidad y dúplex.

3. Los enlaces EtherChannel pueden funcionar como puertos de acceso VLAN o como enlaces troncales entre switches.

4. Todas las interfaces de un EtherChannel de Capa 2 deben ser miembros de la misma VLAN o configurarse como enlaces troncales.

5. Si se configuran como enlaces troncal, EtherChannel de Capa 2 debe tener el mismo Native VLAN y tener las mismas VLAN permitidas en ambos switches conectados al troncal.

6. Al configurar enlaces EtherChannel, todas las interfaces deben apagarse antes de comenzar la configuración de EtherChannel. Una vez completada la configuración, los vínculos se pueden volver a habilitar.

7. Después de configurar el EtherChannel, verifique que todas las interfaces estén en estado de UP/UP.

8. Es posible configurar un EtherChannel como estático, o bien utilizar PAgP o LACP para negociar la conexión EtherChannel. La determinación de cómo se configura un EtherChannel es el valor del comando channel-group number  mode .  Los valores válidos son:

active               LACP siempre está habilitado
passive            LACP sólo está habilitado si se conecta otro dispositivo compatible con LACP.
desirable          PAgP siempre está habilitado
auto                 PAgP sólo está habilitado si se conecta otro dispositivo compatible con PAGP.
on                    EtherChannel está habilitado, pero sin LACP o PAgP.

9. Los puertos LAN pueden formar un EtherChannel usando PAgP si los modos son compatibles. Los modos PAgP compatibles son:

desirable => desirable
desirable => auto
Si ambas interfaces están en modo auto , no se puede formar un Etherchannel.

10. Los puertos LAN pueden formar un EtherChannel usando LACP si los modos son compatibles. Los modos LACP compatibles son:

active => active
activo => passive
Si ambas interfaces están en modo passive, un EtherChannel no puede formarse mediante LACP.

11. Los números de Port Channel son locales para el switch individual. Aunque esta actividad utiliza el mismo número de grupo de canales en cualquiera de los extremos de la conexión EtherChannel, no es un requisito.  El Port Channel 1 (interfaz po1) en un switch puede formar un EtherChannel con el POrt Channel 5 (interfaz po5) en otro switch.

Script de respuesta

Switch S1

enable
config terminal
hostname S1
interface range f0/21 – 22
 switchport mode trunk
 shutdown
 channel-group 1 mode desirable
 no shutdown
interface port-channel 1
 switchport mode trunk
interface range g0/1 - 2
 switchport mode trunk
 shutdown
 channel-group 2 mode active
 no shutdown
interface port-channel 2
 switchport mode trunk
spanning-tree vlan 1 root primary
end

Switch S2

enable
config terminal
hostname S2
interface range g0/1 - 2
 switchport mode trunk
 shutdown
 channel-group 2 mode active
 no shutdown
interface port-channel 2
 switchport mode trunk
interface range f0/23 - 24
 switchport mode trunk
 shutdown
 channel-group 3 mode passive
 no shutdown
interface port-channel 3
 switchport mode trunk
 end

Switch S3

enable
config terminal
hostname S3
interface range f0/21 – 22
 switchport mode trunk
 shutdown
 channel-group 1 mode desirable
 no shutdown
interface port-channel 1
 switchport mode trunk
interface range f0/23 - 24
 switchport mode trunk
 shutdown
 channel-group 3 mode active
 no shutdown
interface port-channel 3
 switchport mode trunk
end

Descargue el archivo de Packet Tracer:

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x