8.2.1.5 Práctica de laboratorio: Configuración del eco del ICMP de IP SLA Respuestas

Última actualización: septiembre 17, 2022

8.2.1.5 Práctica de laboratorio: Configuración del eco del ICMP de IP SLA (versión para el instructor)

Nota para el instructor: el color de fuente rojo o las partes resaltadas en gris indican texto que aparece en la copia del instructor solamente.

Topología

Tabla de asignación de direcciones

Dispositivo Interfaz Dirección IP Máscara de subred Gateway predeterminado
R1 S0/0/0 209.165.200.9 255.255.255.252 N/D
ISP S0/0/0 209.165.200.10 255.255.255.252 N/D
Lo0 198.133.219.1 255.255.255.255 N/D

Objetivos

Parte 1: Armar la red y verificar la conectividad
Parte 2: Configurar el eco ICMP de IP SLA en R1
Parte 3: Probar y monitorear la operación de IP SLA

Aspectos básicos/situación

Se ha contratado a un proveedor externo para proporcionar servicios web para su empresa. En su carácter de administrador de redes, se la ha pedido que supervise el servicio del proveedor. Decide configurar IP SLA para facilitarse esa tarea.

Nota: Los routers que se utilizan en las prácticas de laboratorio de CCNA son routers de servicios integrados (ISR) Cisco de la serie 1941 con Cisco IOS versión 15.2(4)M3 (imagen universalk9). Los switches que se utilizan son Cisco Catalyst 2960s con Cisco IOS versión 15.0(2) (imagen lanbasek9). Se pueden utilizar otros routers, switches y otras versiones de Cisco IOS. Según el modelo y la versión de Cisco IOS, los comandos disponibles y los resultados que se obtienen pueden diferir de los que se muestran en las prácticas de laboratorio. Consulte la tabla Resumen de interfaces del router al final de esta práctica de laboratorio para obtener los identificadores de interfaz correctos.

Nota: Asegúrese de que los routers y los switches se hayan borrado y no tengan configuraciones de inicio. Si no está seguro, consulte al instructor.

Nota para el instructor: consulte el manual de prácticas de laboratorio para el instructor a fin de conocer los procedimientos para inicializar y volver a cargar los dispositivos.

Recursos necesarios

• 2 router (Cisco 1941 con Cisco IOS versión 15.2(4)M3, imagen universal o similar)
• Cables de consola para configurar los dispositivos con Cisco IOS mediante los puertos de consola
• Cable de serie, como se muestra en la topología

Parte 1. Armar la red y verificar la conectividad

En la parte 1, establecerá la topología de la red y configurará los parámetros básicos, como las direcciones IP de interfaz, el routing estático, el acceso a los dispositivos y las contraseñas.

Paso 1. Realizar el cableado de red como se muestra en la topología

Conecte los dispositivos como se muestra en la topología y realice el cableado necesario.

Paso 2. Inicializar y volver a cargar los routers según sea necesario

Paso 3. configurar los parámetros básicos para R1.

a. Desactive la búsqueda de DNS.

b. Configure el nombre del dispositivo como se muestra en la topología.

c. Configure una dirección IP para el router, como se indica en la tabla de asignación de direcciones.

d. Asigne class como la contraseña cifrada del modo EXEC privilegiado.

e. Asigne cisco como contraseña de la consola y vty, habilite el inicio de sesión.

f. Configure logging synchronous para evitar que los mensajes de consola interrumpan la entrada de comandos.

g. Configure la ruta predeterminada para R1 en la dirección IP S0/0/0 del ISP.

h. Copie la configuración en ejecución en la configuración de inicio

Paso 4. Copiar y pegar la configuración en el router ISP.

La configuración del router ISP se indica a continuación. Copie y pegue esta configuración en el router ISP. Se está utilizando Loopback 0 para simular el servidor web que se muestra en la Topología.

hostname ISP
no ip domain lookup
interface Loopback0
 ip address 198.133.219.1 255.255.255.255
interface Serial0/0/0
 ip address 209.165.200.10 255.255.255.252
 no shut
end

Paso 5. Verifique la conectividad.

a. Desde R1 debería poder emitir un ping a la dirección IP de la interfaz de serie. ¿Todos los comandos ping produjeron un resultado correcto?

Si los pings no se realizan correctamente, solucione los problemas de las configuraciones básicas del dispositivo antes de continuar.

b. Desde R1 debería poder emitir un ping a la dirección IP del servidor web. ¿Todos los comandos ping produjeron un resultado correcto?

Si los pings no se realizan correctamente, solucione los problemas de las configuraciones básicas del dispositivo antes de continuar.

Parte 2. Configurar el eco del ICMP de IP SLA en el R1

En la Parte 2 configurará una operación de eco ICMP de IP SLA en R1. Utilice los siguientes parámetros para esta operación:

• Operation-number: 22
• ICMP Echo Destination Address: 198.133.219.1
• Frequency: 20 seconds
• Schedule Start: Now
• Schedule Life time: Forever

Paso 1. Crear una operación de IP SLA.

R1(config)# ip sla 22

Paso 2. Configurar la operación de eco ICMP.

R1(config-ip-sla)# icmp-echo 198.133.219.1

Paso 3. Definir la velocidad con la que se repetirá la operación de IP SLA.

R1(config-ip-sla-echo)# frequency 20

Paso 4. Programar la operación de eco ICMP de IP SLA.

R1(config)# ip sla schedule 22 start-time now life forever

Paso 5. Utilizar el comando show para verificar la configuración de IP SLA.

R1# show ip sla configuration
IP SLAs Infrastructure Engine-III
Entry number: 22
Owner:
Tag:
Operation timeout (milliseconds): 5000
Type of operation to perform: icmp-echo
Target address/Source address: 198.133.219.1/0.0.0.0
Type Of Service parameter: 0x0
Request size (ARR data portion): 28
Verify data: No
Vrf Name:
Schedule:
    Operation frequency (seconds): 20 (not considered if randomly scheduled)
    Next Scheduled Start Time: Start Time already passed
    Group Scheduled : FALSE
    Randomly Scheduled : FALSE
    Life (seconds): Forever
    Entry Ageout (seconds): never
    Recurring (Starting Everyday): FALSE
    Status of entry (SNMP RowStatus): Active
Threshold (milliseconds): 5000
Distribution Statistics:
    Number of statistic hours kept: 2
    Number of statistic distribution buckets kept: 1
    Statistic distribution interval (milliseconds): 20
Enhanced History:
History Statistics:
    Number of history Lives kept: 0
    Number of history Buckets kept: 15
    History Filter Type: None

Parte 3. Probar y supervisar la operación de IP SLA

En la Parte 3 simulará una interrupción de los servicios web. Esto puede hacerse apagando la interfaz loopback 0 administrativamente en el router ISP. Luego mostrará las estadísticas de la operación de IP SLA para monitorear el efecto de esta prueba.

Paso 1. Apagar la interfaz loopback 0 en el router ISP.

ISP (config) # interface Lo0
ISP(config-if)# shutdown
ISP (config-if) #
*Nov 28 14:00:52.823: %LINK-5-CHANGED: Interface Loopback0, changed state to
administratively down
*Nov 28 14:00:53.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to down
ISP (config-if) #

Nota: Aguarde algunos minutos antes de ejecutar el Paso 2.

Paso 2. Activar la interfaz loopback 0 en el router ISP.

R2(config-if)# no shutdown
R2(config-if)#
*Nov 28 14:04:23.263: %LINK-3-UPDOWN: Interface Loopback0, changed state to up
*Nov 28 14:04:24.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to up
R2(config-if)#

Paso 3. Emitir el comando que se utiliza para mostrar las estadísticas de la operación de IP SLA en R1.

R1# show ip sla statistics
IPSLAs Latest Operation Statistics

IPSLA operation id: 22
      Latest RTT: 1 milliseconds
Latest operation start time: 18:44:45 UTC Thu Jan 28 2016
Latest operation return code: OK
Number of successes: 103
Number of failures: 10
Operation time to live: Forever

Nota: Debería ver un conteo de falla con valor positivo si aguardó más de 20 segundos antes de reactivar la interfaz loopback 0 en el router ISP.

La IP SLA configurada en la Parte 2 se ejecutará indefinidamente. ¿Cómo detendría la ejecución de la IP SLA y, a la vez, dejarla configurada para utilizarla en otro momento?

R1(config)# no ip sla schedule 22

Reflexión

Si recurre al ejemplo de show ip sla statistics, ¿qué indica el conteo de falla con respecto al servidor web?

Las respuestas variarán, pero esta cantidad muestra que la operación de eco del ICMP de IP SLA no pudo llegar al servidor web 10 veces desde el comienzo de la operación de supervisión de IP SLA. Se puede interpretar que hubo aproximadamente 3 minutos de interrupciones de los servicios web desde el 28 de enero de 2016, a las 6:45 p. m. Sin embargo, no se sabe si fue un incidente prolongado (aproximadamente 3 minutos) o si fueron varios incidentes más breves.

Tabla de resumen de interfaces de router

Resumen de interfaces de router
Modelo de router Interfaz Ethernet 1 Interfaz Ethernet 2 Interfaz serial 1 Interfaz serial 2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Nota: Para conocer la configuración del router, observe las interfaces a fin de identificar el tipo de router y cuántas interfaces tiene. No existe una forma eficaz de hacer una lista de todas las combinaciones de configuraciones para cada clase de router. En esta tabla se incluyen los identificadores para las posibles combinaciones de interfaces Ethernet y seriales en el dispositivo. En esta tabla, no se incluye ningún otro tipo de interfaz, si bien puede haber interfaces de otro tipo en un router determinado. La interfaz BRI ISDN es un ejemplo. La cadena entre paréntesis es la abreviatura legal que se puede utilizar en un comando de Cisco IOS para representar la interfaz.

Configuraciones de dispositivos

  • Router R1
  • Router ISP
R1#show run
Building configuration...

Current configuration : 1577 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$papm$awGgHPitBMUA2.bImJtdp0
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 209.165.200.9 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 209.165.200.10
!
ip sla 22
icmp-echo 198.133.219.1
frequency 20
ip sla schedule 22 life forever start-time now
!
control-plane
!
line con 0
password cisco
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input none
!
scheduler allocate 20000 1000
!
end
ISP# show run
Building configuration...

Current configuration : 1360 bytes
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
interface Loopback0
ip address 198.133.219.1 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 209.165.200.10 255.255.255.252
!
interface Serial0/0/1
no ip address
shutdown
clock rate 125000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
línea con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x