9.3.1.3 Proyecto final de OSPF Respuestas

Última actualización: septiembre 9, 2022

9.3.1.3 Proyecto final de OSPF (versión para el instructor)

Nota para el instructor: el color de fuente rojo o las partes resaltadas en gris indican texto que aparece en la copia del instructor solamente.

Objetivos

• Configurar OSPFv2 básico para habilitar las comunicaciones de internetwork en una red IPv4 de una pequeña a mediana empresa.

• Implementar características avanzadas de OSPF para mejorar el funcionamiento en una red de una pequeña a mediana empresa.

• Implementar OSPF multiárea para IPv4 para habilitar las comunicaciones de internetwork en una red de una pequeña a mediana empresa.

• Configurar OSPFv3 básico para habilitar las comunicaciones de internetwork en una red IPv6 de una pequeña a mediana empresa.

Notas para el instructor:

• Los estudiantes deben poder diseñar, configurar y proteger OSPF en una red.

• El registro es un factor importante de este proyecto, y los estudiantes deben poder explicar el diseño y la verificación de la red mediante el uso de los comandos show.

• Nota con respecto a esta actividad:
– Conviene realizarla en grupos de dos a tres estudiantes.
– Se sugiere que sea una asignación con calificación para realizar después de completar todos los capítulos de OSPF.

Situación

Su empresa tomó la decisión de implementar el protocolo de routing OSPF en la red. Decidió que debe revisar los conceptos relacionados con OSPF, a fin de realizar una transición sin problemas a este protocolo.

Utilice Packet Tracer para crear una red. Configure la red con estas opciones del protocolo de routing OSPF:

• OSPFv2 multiárea
• OSPFv3 de área única
• Ancho de banda
• Costo
• Autenticación
• Rutas predeterminadas
• Elecciones del DR y del BDR para los segmentos

Recursos necesarios

• Packet Tracer
• Tabla de evaluación creada por el estudiante o el grupo para evaluar la asignación

Paso 1: Diseñar y armar una red desde cero.

a. El diseño debe incluir tres routers conectados a una red de accesos múltiples en el área 0 para usar con IPv4.

1) Habilite la autenticación.
2) Establezca el DR y el BDR mediante el comando router id.

Paso 2: Agregar un router adicional con dos conexiones al área 0, de modo que se represente otra área OSPF.

Paso 3: Configurar el ancho de banda o el costo para que favorezcan una ruta.

Paso 4: Agregar una red que contenga terminales y una interfaz OSPF pasiva.

Paso 5: Agregar una ruta a la red predeterminada, como Internet.

Paso 6: Agregar un esquema de direccionamiento IPv6 en los routers y configurar OSPFv3.

a. Habilite el routing de unidifusión IPv6.

b. Establezca el DR y el BDR mediante el comando router id.

c. No configure los temporizadores, el ancho de banda, el costo, las rutas predeterminadas o la autenticación.

Tabla de calificación de ejemplo para el instructor

Esta tabla de calificación de ejemplo incluye un total de 100 puntos para la categoría de puntos obtenidos (si se cumplen los estándares mínimos). Los instructores podrán considerar agregar puntos extra por trabajo adicional o avanzado en cualquier categoría de requisitos.

Requisito Puntos obtenidos
Topología física
• Hay un mínimo de tres routers en el área 0.
• Hay un router en otra área.
• Hay una conexión a Internet con una computadora en la topología.
(10 sugeridos)
Direccionamiento lógico y conectividad
• Las redes IPv4 e IPv6 deben tener plena conectividad. La conectividad se verifica mediante pings a todo IP, incluso Internet.
(20 sugeridos)
Requisito 1 de OSPF
• Existen dos áreas OSPFv2.
• Existen dos áreas OSPFv3.
(20 sugeridos)
Requisito 2 de OSPF
• La autenticación y las interfaces pasivas de OSPF se utilizan para proteger el protocolo.
(20 sugeridos)
Requisito 3 de OSPF
• Las ID del router se utilizan para la elección del DR y del BDR.
(10 sugeridos)
Requisito 4 de OSPF
• El costo de OSPF se modifica para manipular las rutas preferidas.
(10 sugeridos)
Requisito 5 de OSPF
• Las rutas estáticas y la información predeterminada producida se utilizan para poder acceder a Internet.
(10 sugeridos)

Solución de ejemplo de topología para el instructor

Tabla de direccionamiento sugerida 

Dispositivo Interfaz Dirección IPv4 Máscara de
subred
Gateway
predeterminado
Dirección/Prefijo IPv6 Id. de router
R1 G0/0 172.16.1.1 255.255.255.0 10.1.1.1
G0/2 10.0.0.1 255.255.255.0
G0/0 2001:DB8:1:11::1/64
G0/2 2001:DB8:1:123::1/64
Link-local FE80::1
R2 G0/0 172.16.2.1 255.255.255.0 10.2.2.2
G0/2 10.0.0.2 255.255.255.0
S0/0/0 64.104.73.242 255.255.255.240
G0/0 2001:DB8:1:22::1/64
G0/2 2001:DB8:1:123::2/64
S0/0/0 2001:DB8:1:2::1/64
Link-local FE80::2
R3 G0/0 172.16.0.1 255.255.255.0 10.3.3.3
G0/2 10.0.0.2 255.255.255.0
G0/0 2001:DB8:1:33::1/64
G0/2 2001:DB8:1:123::3/64
Link-local FE80::3
A2 G0/0 172.16.2.2 255.255.255.0 2.2.2.2
G0/2 172.16.1.2 255.255.255.0
G0/0 2001:DB8:1:22::2/64
G0/2 2001:DB8:1:11::2/64
Link-local FE80::A
L3 NIC 172.16.0.1 255.255.255.0 172.16.0.1
NIC 2001:DB8:1:33::1/64 FE80::3

Configuraciones de dispositivos después de la realización de esta actividad

R1# show run
Building configuration...

Current configuration : 1291 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
ipv6 unicast-routing
!
license udi pid CISCO2911/K9 sn FTX1524UZ5Y
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 172.16.1.1 255.255.255.0
ip ospf message-digest-key 1 md5 Area2
duplex auto
speed auto
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:1:11::1/64
ipv6 ospf 1 area 2
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
ip address 10.0.0.1 255.255.255.0
ip ospf message-digest-key 1 md5 Area0
duplex auto
speed auto
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:1:123::1/64
ipv6 ospf 1 area 0
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 10.1.1.1
log-adjacency-changes
area 0 authentication message-digest
area 2 authentication message-digest
network 10.0.0.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 2
!
ipv6 router ospf 1
router-id 10.1.1.1
log-adjacency-changes
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

R2# show run
Building configuration...

Current configuration : 1494 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
ipv6 unicast-routing
!
license udi pid CISCO2911/K9 sn FTX1524GRRS
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 172.16.2.1 255.255.255.0
ip ospf message-digest-key 1 md5 Area2
duplex auto
speed auto
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:1:22::1/64
ipv6 ospf 1 area 2
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
ip address 10.0.0.2 255.255.255.0
ip ospf message-digest-key 1 md5 Area0
duplex auto
speed auto
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:1:123::2/64
ipv6 ospf 1 area 0
!
interface Serial0/0/0
ip address 64.104.73.242 255.255.255.240
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:1:2::1/64
ipv6 ospf 1 area 0
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 10.2.2.2
log-adjacency-changes
area 0 authentication message-digest
area 2 authentication message-digest
passive-interface Serial0/0/0
network 10.0.0.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 2
default-information originate
!
ipv6 router ospf 1
router-id 10.2.2.2
log-adjacency-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

R3# show run
Building configuration...

Current configuration : 1291 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
ipv6 unicast-routing
!
license udi pid CISCO2911/K9 sn FTX15247W10
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip ospf message-digest-key 1 md5 Area0
duplex auto
speed auto
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:1:33::1/64
ipv6 ospf 1 area 0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
ip address 10.0.0.3 255.255.255.0
ip ospf message-digest-key 1 md5 Area0
duplex auto
speed auto
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:1:123::3/64
ipv6 ospf 1 area 0
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 10.3.3.3
log-adjacency-changes
area 0 authentication message-digest
passive-interface GigabitEthernet0/0
network 10.0.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.255 area 0
!
ipv6 router ospf 1
router-id 10.3.3.3
log-adjacency-changes
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

A2# show run
Building configuration...

Current configuration : 1157 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname A2
!
ipv6 unicast-routing
!
license udi pid CISCO2911/K9 sn FTX1524DVBW
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 172.16.2.2 255.255.255.0
ip ospf message-digest-key 1 md5 Area2
ip ospf cost 2000
duplex auto
speed auto
ipv6 address FE80::A link-local
ipv6 address 2001:DB8:1:22::2/64
ipv6 ospf 1 area 2
!
interface GigabitEthernet0/1
ip address 172.16.1.2 255.255.255.0
ip ospf message-digest-key 1 md5 Area2
ip ospf cost 1000
duplex auto
speed auto
ipv6 address FE80::A link-local
ipv6 address 2001:DB8:1:11::2/64
ipv6 ospf 1 area 2
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
area 2 authentication message-digest
network 172.16.2.0 0.0.0.255 area 2
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
!
ip classless
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
End

Show IP route

R1>en  
R1# show ip route  
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area  
       * - candidate default, U - per-user static route, o - ODR  
       P - periodic downloaded static route  
  
Gateway of last resort is 10.0.0.2 to network 0.0.0.0  
  
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks  
C       10.0.0.0/24 is directly connected, GigabitEthernet0/2  
L       10.0.0.1/32 is directly connected, GigabitEthernet0/2  
     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks  
O       172.16.0.0/24 [110/2] via 10.0.0.3, 00:02:18, GigabitEthernet0/2  
C       172.16.1.0/24 is directly connected, GigabitEthernet0/0  
L       172.16.1.1/32 is directly connected, GigabitEthernet0/0  
O IA    172.16.2.0/24 [110/2] via 10.0.0.2, 00:02:18, GigabitEthernet0/2  
O*E2 0.0.0.0/0 [110/1] via 10.0.0.2, 00:02:18, GigabitEthernet0/2

Show IP protocols

R1# show ip protocols  
  
Routing Protocol is "ospf 1"  
  Outgoing update filter list for all interfaces is not set   
  Incoming update filter list for all interfaces is not set   
  Router ID 10.1.1.1  
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa  
  Maximum path: 4  
  Routing for Networks:  
    10.0.0.0 0.0.0.255 area 0  
    172.16.1.0 0.0.0.255 area 2  
  Routing Information Sources:    
    Gateway         Distance      Last Update   
    10.1.1.1             110      00:08:18  
    10.2.2.2             110      00:07:29  
    10.3.3.3             110      00:07:38  
  Distance: (default is 110)

Show IP OSPF neighbor

R1# show ip ospf neighbor  
  
Neighbor ID     Pri   State           Dead Time   Address         Interface  
10.3.3.3          1   FULL/DR         00:00:33    10.0.0.3        GigabitEthernet0/2  
10.2.2.2          1   FULL/BDR        00:00:33    10.0.0.2        GigabitEthernet0/2

Show IP interface brief

R1# show ip int brief  
Interface              IP-Address      OK? Method Status                Protocol  
   
GigabitEthernet0/0     172.16.1.1      YES manual up                    up  
   
GigabitEthernet0/1     unassigned      YES unset  administratively down down  
   
GigabitEthernet0/2     10.0.0.1        YES manual up                    up  
   
Serial0/0/0            unassigned      YES unset  administratively down down  
   
Serial0/0/1            unassigned      YES unset  administratively down down  
   
Vlan1                  unassigned      YES unset  administratively down down

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x