3.2.2.7 Práctica de laboratorio: Configuración de un router como cliente PPPoE para conectividad DSL Respuestas

Última actualización: septiembre 16, 2022

3.2.2.7 Práctica de laboratorio: Configuración de un router como cliente PPPoE para conectividad DSL (versión para el instructor)

Nota para el instructor: el color de fuente rojo o las partes resaltadas en gris indican texto que aparece en la copia del instructor solamente.

Topología

Tabla de asignación de direcciones

Dispositivo Interfaz Dirección IP Máscara de subred Gateway predeterminado
Cust1 G0/1 Conocidas a través de PPP Conocidas a través de PPP Conocidas a través de PPP
ISP G0/1 N/D N/D N/D

Objetivos

Parte 1: Armar la red
Parte 2: Configurar el router de ISP
Parte 3: Configurar el router de Cust1

Aspectos básicos/situación

Por lo general, los ISP utilizan el protocolo punto a punto por Ethernet (PPPoE) en los enlaces DSL a sus clientes. PPP admite la asignación de información de direcciones IP a un dispositivo en el extremo remoto de un enlace PPP. Lo que es más importante, PPP admite la autenticación CHAP. Los ISP pueden revisar los registros contables para ver si la factura de un cliente figura como paga antes de permitirles conectarse a Internet.

En esta práctica de laboratorio, configurará el lado de la conexión tanto del cliente como del ISP para configurar PPPoE. Generalmente, solo se configura el extremo del cliente.

Nota: Los routers que se utilizan en las prácticas de laboratorio de CCNA son routers de servicios integrados (ISR) Cisco de la serie 1941 con Cisco IOS versión 15.2(4)M3 (imagen universalk9). Los switches que se utilizan son Cisco Catalyst 2960s con Cisco IOS versión 15.0(2) (imagen lanbasek9). Se pueden utilizar otros routers, switches y otras versiones de Cisco IOS. Según el modelo y la versión de Cisco IOS, los comandos disponibles y los resultados que se obtienen pueden diferir de los que se muestran en las prácticas de laboratorio. Consulte la tabla Resumen de interfaces del router al final de esta práctica de laboratorio para obtener los identificadores de interfaz correctos.

Nota: Asegúrese de que los routers y los switches se hayan borrado y no tengan configuraciones de inicio. Si no está seguro, consulte al instructor.

Nota para el instructor: consulte el manual de prácticas de laboratorio para el instructor a fin de conocer los procedimientos para inicializar y volver a cargar los dispositivos.

Recursos necesarios

• 2 routers (Cisco 1941 con Cisco IOS versión 15.2(4)M3, imagen universal o similar)
• 2 switches (Cisco 2960 con Cisco IOS versión 15.0(2), imagen lanbasek9 o comparable)
• Cables de consola para configurar los dispositivos con Cisco IOS mediante los puertos de consola
• Cables Ethernet, como se muestra en la topología

Parte 1: Crear la red

Paso 1: Realizar el cableado de red tal como se muestra en la topología.

Paso 2: Inicializar y volver a cargar los routers y los switches

Paso 3: Configurar los parámetros básicos para cada router

a. Desactive la búsqueda de DNS.

b. Configure el nombre del dispositivo como se muestra en la topología.

c. Cifre las contraseñas no cifradas.

d. Cree un aviso de mensaje del día (MOTD) para advertir a los usuarios que el acceso no autorizado está prohibido.

e. Asigne class como la contraseña cifrada del modo EXEC privilegiado.

f. Asigne cisco como la contraseña de vty y la contraseña de consola, y habilite el inicio de sesión.

g. Establezca el inicio de sesión de consola en modo sincrónico.

h. Guarde su configuración.

Parte 2: Configurar el router ISP

En la parte 2, configurará el router ISP con los parámetros de PPPoE para la conexión desde el router Cust1.

Nota: muchos de los comandos de configuración de PPPoE del router ISP exceden el ámbito del curso; sin embargo, son necesarios para completar la práctica de laboratorio. Se pueden copiar y pegar en el router ISP, en la petición de entrada del modo de configuración global.

a. Cree el nombre de usuario Cust1 para la base de datos local, con la contraseña ciscopppoe.

ISP (config) # ciscopppoe username RTR_A password Cust1

b. Cree el conjunto de direcciones que se asignará a los clientes.

ISP(config)# ip local pool PPPoEPOOL 10.0.0.1 10.0.0.10

c. Cree la plantilla virtual y asóciela a la dirección IP de G0/1. Asocie la plantilla virtual al conjunto de direcciones. Configure CHAP para autenticar a los clientes.

ISP(config)# interface virtual-template 1
ISP(config-if)# ip address 10.0.0.254 255.255.255.0
ISP (config-if) # mtu 1492
ISP (config-if) # peer default ip address pool PPPoEPOOL
ISP(config-if)# ppp authentication chap callin
ISP(config-if)# exit

d. Asigne la plantilla al grupo de PPPoE.

ISP (config) # pppoe de bba- grupo global
ISP (Config-bba- grupo) # virtual-template 1
ISP(config-bba-group)# exit

e. Asocie bba-group a la interfaz física G0/1.

ISP(config)# interface g0/1
ISP (grupo de enable traps pppoe de config-subif) if# global
ISP(config-if)# no shutdown

Parte 3: Configurar el router Cust1

En la parte 3, configurará el router Cust1 con los parámetros de PPPoE.

a. Configure la interfaz G0/1 para la conectividad PPPoE.

Cust1(config)# interface g0/1
Cust1 (config-if) # enable traps pppoe
Cust1 (config-if) # marcado-conjunto- número 1 del cliente PPPoE
Cust1(config-if)# exit

b. Asocie la interfaz G0/1 a una interfaz de marcador. Utilice el nombre de usuario Cust1 y la contraseña ciscopppoe que se configuraron en la parte 2.

Cust1(config)# interface dialer 1
Cust1 (config-if) # mtu 1492
Cust1(config-if)# ip address negotiated
Cust1(config-if)# encapsulation ppp
Cust1(config-if)# dialer pool 1
Cust1(config-if)# ppp authentication chap callin
Cust1(config-if)# ppp chap hostname Cust1
Cust1 (config-if) # ppp chap password ciscopppoe
Cust1(config-if)# exit

c. Establezca una ruta estática predeterminada que apunte a la interfaz del marcador.

Cust1(config)# ip route 0.0.0.0 0.0.0.0 dialer 1

d. Establezca la depuración en el router Cust1 para mostrar la negociación PPP y PPPoE.

Cust1# debug ppp authentication
Eventos de pppoe de depuración de Cust1#

e. Habilite la interfaz G0/1 en el router Cust1 y observe el resultado de debug a medida que se establece la sesión del marcador de PPPoE y que ocurre la autenticación CHAP.

Cust1(config)# interface g0/1
Cust1(config-if)# no shutdown

*Jul 30 19:28:42.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to
down
*Jul 30 19:28:46.175: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to
up
*Jul 30 19:28:47.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface
GigabitEthernet0/1, changed state to up
*Jul 30 19:29:03.839: padi timer expired
*Jul 30 19:29:03.839: Sending PADI: Interface = GigabitEthernet0/1
*Jul 30 19:29:03.839: PPPoE 0: I PADO R:30f7.0da3.0b01 L:30f7.0da3.0bc1 Gi0/1
*Jul 30 19:29:05.887: PPPOE: we've got our pado and the pado timer went off
*Jul 30 19:29:05.887: OUT PADR from PPPoE Session
*Jul 30 19:29:05.895: PPPoE 1: I PADS R:30f7.0da3.0b01 L:30f7.0da3.0bc1 Gi0/1
*Jul 30 19:29:05.895: IN PADS from PPPoE Session
*Jul 30 19:29:05.899: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Jul 30 19:29:05.899: PPPoE: Virtual Access interface obtained.
*Jul 30 19:29:05.899: PPPoE : encap string prepared
*Jul 30 19:29:05.899: [0]PPPoE 1: data path set to PPPoE Client
*Jul 30 19:29:05.903: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Jul 30 19:29:05.911: Vi2 PPP: Using dialer call direction
*Jul 30 19:29:05.911: Vi2 PPP: Treating connection as a callout
*Jul 30 19:29:05.911: Vi2 PPP: Session handle[C6000001] Session id[1]
*Jul 30 19:29:05.919: Vi2 PPP: No authorization without authentication
*Jul 30 19:29:05.939: Vi2 CHAP: I CHALLENGE id 1 len 24 from "ISP"
* De julio de 19:05: 29:05.939: Vi2 PPP: Solicitud enviada de CHAP SENDAUTH
* De julio de 19:05: 29:05.939: Vi2 PPP: FAIL recibido de la respuesta de SENDAUTH
*Jul 30 19:29:05.939: Vi2 CHAP: Using hostname from interface CHAP
*Jul 30 19:29:05.939: Vi2 CHAP: Using password from interface CHAP
*Jul 30 19:29:05.939: Vi2 CHAP: O RESPONSE id 1 len 26 from "Cust1"
*Jul 30 19:29:05.955: Vi2 CHAP: I SUCCESS id 1 len 4
*Jul 30 19:29:05.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2,
changed state to up
* De julio de 19:05: 29:05.983: PPPoE: ipfib_encapstr preparado
* De julio de 19:05: 29:05.983: PPPoE: ipfib_encapstr preparado

f. Emita un comando show ip interface brief en el router Cust1 para mostrar la dirección IP que asignó el router ISP. A continuación, se muestra un ejemplo de resultado. ¿Mediante qué método se obtuvo la dirección IP?
PPP

Cust1# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down  
GigabitEthernet0/0         unassigned      YES unset  administratively down down  
GigabitEthernet0/1         unassigned      YES unset  up                    up  
Serial0/0/0                unassigned      YES unset  administratively down down  
Serial0/0/1                unassigned      YES unset  administratively down down  
Dialer1                    10.0.0.1        YES IPCP   up                    up  
Virtual-Access1            unassigned      YES unset  up                    up  
Virtual-Access2            unassigned      YES unset  up                    up

g. Emita un comando show ip route en el router Cust1. A continuación, se muestra un ejemplo de resultado.

Cust1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 0.0.0.0 to network 0.0.0.0  
  
S*    0.0.0.0/0 is directly connected, Dialer1  
      10.0.0.0/32 is subnetted, 2 subnets  
C        10.0.0.1 is directly connected, Dialer1  
C        10.0.0.254 is directly connected, Dialer1

h. Emita un comando show pppoe session en el router Cust1. A continuación, se muestra un ejemplo de resultado.

Cust1# show pppoe session
     1 client session  
  
Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           Tipo generación de SID LocMAC VA-st Type  
    N/A 1 30f7.0da3.0b01 Gi0/1 Di1 Vi2 UP   
                30f7.0da3.0bc1 UP

i. Haga ping a 10.0.0.254 desde el router Cust1. El ping debería realizarse correctamente. De lo contrario, resuelva los problemas hasta que haya conectividad.

Cust1# ping 10.0.0.254
Escriba la secuencia de escape para interrumpir la acción.
Sending 5, 100-byte ICMP Echos to 10.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Reflexión

¿Por qué los ISP que utilizan DSL usan principalmente PPPoE con sus clientes?

El protocolo PPP admite la autenticación a través de un enlace Ethernet. Los ISP pueden autenticar a los clientes y emitir una dirección IP.

Tabla de resumen de interfaces de router

Resumen de interfaces de router
Modelo de router Interfaz Ethernet 1 Interfaz Ethernet 2 Interfaz serial 1 Interfaz serial 2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Nota: Para conocer la configuración del router, observe las interfaces a fin de identificar el tipo de router y cuántas interfaces tiene. No existe una forma eficaz de hacer una lista de todas las combinaciones de configuraciones para cada clase de router. En esta tabla se incluyen los identificadores para las posibles combinaciones de interfaces Ethernet y seriales en el dispositivo. En esta tabla, no se incluye ningún otro tipo de interfaz, si bien puede haber interfaces de otro tipo en un router determinado. La interfaz BRI ISDN es un ejemplo. La cadena entre paréntesis es la abreviatura legal que se puede utilizar en un comando de Cisco IOS para representar la interfaz.

Configuraciones de dispositivos

  • Router Cust1
  • Router ISP
Cust1# show run
Building configuration...
Current configuration : 1433 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cust1
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname Cust1
ppp chap password 0 ciscopppoe
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
control-plane
!
banner motd ^C
Unauthorized Access Prohibited.
^C
!
line con 0
password 7 14141B180F0B
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 05080F1C2243
login
transport input all
!
scheduler allocate 20000 1000
!
end
ISP# show run
Building configuration...
Current configuration : 1485 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
ciscopppoe de la contraseña 0 de nombre de usuario Cust1
!
bba-group pppoe global
virtual-template 1
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable group global
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Virtual-Template1
ip address 10.0.0.254 255.255.255.0
mtu 1492
peer default ip address pool PPPoEPOOL
ppp authentication chap callin
!
ip local pool PPPoEPOOL 10.0.0.1 10.0.0.10
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^C
Unauthorized Access Prohibited.
^C
!
line con 0
password 7 14141B180F0B
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 05080F1C2243
login
transport input all
!
scheduler allocate 20000 1000
!
end

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x