3.2.2.8 Práctica de laboratorio: Solución de problemas de PPPoE Respuestas

Última actualización: septiembre 16, 2022

3.2.2.8 Práctica de laboratorio: Solución de problemas de PPPoE (Versión para el instructor)

Nota para el instructor: el color de fuente rojo o las partes resaltadas en gris indican texto que aparece en la copia del instructor solamente.

Topología

Tabla de asignación de direcciones

Dispositivo Interfaz Dirección IP Máscara de subred Gateway predeterminado
Cust1 G0/1 Conocidas a través de PPP Conocidas a través de PPP Conocidas a través de PPP
ISP G0/1 N/D N/D N/D

Objetivos

Parte 1: Armar la red
Parte 2: Solucionar problemas del PPPoE en Cust1

Aspectos básicos/situación

Los ISP a veces utilizan el protocolo punto a punto por Ethernet (PPPoE) en los enlaces DSL a sus clientes. PPP admite la asignación de información de direcciones IP a un dispositivo en el extremo remoto de un enlace PPP. Lo que es más importante, PPP admite la autenticación CHAP. Los ISP pueden revisar los registros contables para ver si la factura de un cliente figura como paga antes de permitirles conectarse a Internet.

En esta actividad de laboratorio, solucionará problemas del router Cust1 para la configuración del PPPoE.

Nota: Los routers que se utilizan en las prácticas de laboratorio de CCNA son routers de servicios integrados (ISR) Cisco de la serie 1941 con Cisco IOS versión 15.2(4)M3 (imagen universalk9). Los switches que se utilizan son Cisco Catalyst 2960s con Cisco IOS versión 15.0(2) (imagen lanbasek9). Se pueden utilizar otros routers, switches y otras versiones de Cisco IOS. Según el modelo y la versión de Cisco IOS, los comandos disponibles y los resultados que se obtienen pueden diferir de los que se muestran en las prácticas de laboratorio. Consulte la tabla Resumen de interfaces del router al final de esta práctica de laboratorio para obtener los identificadores de interfaz correctos.

Nota: Asegúrese de que los routers y los switches se hayan borrado y no tengan configuraciones de inicio. Si no está seguro, consulte al instructor.

Nota para el instructor: consulte el manual de prácticas de laboratorio para el instructor a fin de conocer los procedimientos para inicializar y volver a cargar los dispositivos.

Recursos necesarios

• 2 routers (Cisco 1941 con Cisco IOS versión 15.2(4)M3, imagen universal o similar)
• 2 switches (Cisco 2960 con Cisco IOS versión 15.0(2), imagen lanbasek9 o comparable)
• Cables de consola para configurar los dispositivos con Cisco IOS mediante los puertos de consola
• Cables Ethernet, como se muestra en la topología

Parte 1: Crear la red

Paso 1: Realizar el cableado de red tal como se muestra en la topología.

Paso 2: Inicializar y volver a cargar los routers y los switches

Paso 3: Copiar la configuración en los routers.

a. Copie y pegue la configuración de Cust1 en el router Cust1.

hostname Cust1
enable secret class
no aaa new-model
no ip domain lookup
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no shut
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname Cust1
ppp chap password 0 ciscoppp
ip route 0.0.0.0 0.0.0.0 Dialer1
banner motd ^C
Unauthorized Access Prohibited.
^C
línea con 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
end

b. Copie y pegue la configuración del ISP en el router ISP.

hostname ISP
enable secret class
ciscopppoe de la contraseña 0 de nombre de usuario Cust1
pppoe de bba- grupo global
virtual-template 1
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
grupo de enable traps pppoe global
no shut
interface Virtual-Template1
ip address 10.0.0.254 255.255.255.0
mtu 1492
peer default ip address pool PPPoEPOOL
ppp authentication chap callin
ip local pool PPPoEPOOL 10.0.0.1 10.0.0.10
ip forward-protocol nd
banner motd ^C
Unauthorized Access Prohibited.
^C
línea con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
login
end

Nota: Muchos de los comandos de configuración del PPPoE del router ISP exceden el ámbito del curso.

c. Guarde la configuración del router.

Parte 2: Solucionar problemas del PPPoE en Cust1

En la parte 2, solucionará problemas del PPPoE en el router Cust1. La contraseña del modo EXEC con privilegios es class, y las contraseñas de consola y de vty es cisco. El ISP proporcionó un nombre de usuario Cust1 y la contraseña ciscopppoe para la autenticación CHAP del PPPoE.

Los siguientes mensajes de registro deben aparecer en su sesión de consola de Cust1:

Cust1#
*Nov 5 22:53:46.999: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Nov 5 22:53:47.003: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Nov 5 22:53:47.035: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Nov 5 22:53:47.039: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
Cust1#

Paso 1: Comprobar que la dirección IPv4 esté asignada a la interfaz de marcador Cust1.

La interfaz virtual de marcador no recibió una dirección IP.

Cust1# show ip interface brief  
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down      
GigabitEthernet0/0         unassigned      YES unset  administratively down down      
GigabitEthernet0/1         unassigned      YES unset  up                    up        
Serial0/0/0                unassigned      YES unset  administratively down down      
Serial0/0/1                unassigned      YES unset  administratively down down      
Dialer1                    unassigned      YES manual up                    up        
Virtual-Access1            unassigned      YES unset  up                    up        
Virtual-Access2            unassigned      YES unset  down                  down

Paso 2: Depurar el PPP para determinar si el problema está relacionado con la autenticación.

a. Active la depuración para la autenticación del PPP.

Cust1# debug ppp authentication
PPP authentication debugging is on
Cust1#
*Nov 5 23:09:00.283: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Nov 5 23:09:00.287: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Nov 5 23:09:00.287: Vi2 PPP: Using dialer call direction
*Nov 5 23:09:00.287: Vi2 PPP: Treating connection as a callout
*Nov 5 23:09:00.287: Vi2 PPP: Session handle[8A000036] Session id[54]
*Nov 5 23:09:00.315: Vi2 PPP: No authorization without authentication
*Nov 5 23:09:00.315: Vi2 CHAP: I CHALLENGE id 1 len 24 from "ISP"
*Nov 5 23:0
Cust1#9: 00.315: Vi2 PPP: Solicitud enviada de CHAP SENDAUTH
*Nov 5 23:09:00.315: Vi2 PPP: Received SENDAUTH Response FAIL
*Nov 5 23:09:00.315: Vi2 CHAP: Using hostname from interface CHAP
*Nov 5 23:09:00.315: Vi2 CHAP: Using password from interface CHAP
*Nov 5 23:09:00.315: Vi2 CHAP: O RESPONSE id 1 len 26 from "Cust1"
*Nov 5 23:09:00.315: Vi2 CHAP: I FAILURE id 1 len 25 msg is "Authentication failed"
*Nov 5 23:09:00.315: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Nov 5 23:09:00.319: %LINK-3
Cust1#-UPDOWN: Virtual-Access2 Interfaz, changed state to down
Cust1#

b. Cierre el modo de depuración.

Cust1# u all
All possible debugging has been turned off
Cust1#

Paso 3: Comprobar que el nombre de usuario y la contraseña del PPPoE coincidan con lo provisto por el ISP.

a. Visualice la configuración en ejecución; aplique un filtro para ver solamente la sección de marcadores. Compruebe que el nombre de usuario y la contraseña coincidan con lo provisto por el ISP.

Show run Cust1# | marcador de la sección
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname Cust1
ppp chap password 0 ciscoppp
ip route 0.0.0.0 0.0.0.0 Dialer1

b. El problema parece ser la contraseña. Ingrese al modo de configuración global y corrija la contraseña de PPP.

Cust1# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Cust1 (config) # interface Dialer1
Cust1 (config-if) # ppp chap password ciscopppoe
Cust1(config-if)# end
Cust1#
*Nov 5 23:42:07.343: %SYS-5-CONFIG_I: Configured from console by console
Cust1#
*Nov 5 23:42:25.039: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Nov 5 23:42:25.043: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
Cust1#
*Nov 5 23:42:25.063: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2,
changed state to up

Paso 4: Comprobar la conectividad del PPPoE.

a. Compruebe que este cambio haya resuelto el problema y que se haya asignado una dirección IP a la interfaz Dialer1.

Cust1# show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES unset  administratively down down
GigabitEthernet0/0         unassigned      YES unset  administratively down down
GigabitEthernet0/1         unassigned      YES unset  up                    up
Serial0/0/0                unassigned      YES unset  administratively down down
Serial0/0/1                unassigned      YES unset  administratively down down
Dialer1                    10.0.0.1        YES IPCP   up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up

b. Visualice la tabla de routing para comprobar una ruta al router ISP.

Cust1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       a - application route  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 0.0.0.0 to network 0.0.0.0  
  
S*    0.0.0.0/0 is directly connected, Dialer1  
      10.0.0.0/32 is subnetted, 2 subnets  
C        10.0.0.1 is directly connected, Dialer1  
C        10.0.0.254 is directly connected, Dialer1

c. Visualice la información sobre las sesiones del PPPoE activas.

Cust1# show pppoe session
     1 client session   
  
Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           Tipo generación de SID LocMAC VA-st Type  
    N/A      1  30f7.0da3.1641  Gi0/1                   Di1 Vi2        UP
                30f7.0da3.0da1                              UP

Paso 5: Ajustar el tamaño máximo del segmento en la interfaz física.

El encabezado del PPPoE agrega 8 bytes adicionales a cada segmento. Para evitar que las sesiones TCP se caigan, se debe ajustar el tamaño máximo del segmento (MSS, maximum segment size) a su valor óptimo en la interfaz física.

a. Visualice los ajustes de configuración de G0/1s para ver si se ajustó el MSS.

Cust1# show run interface g0/1
Building configuration...

Current configuration : 136 bytes
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
end

b. Ajuste el MSS a su valor óptimo de 1452 bytes.

Cust1(config)# interface g0/1
Cust1(config-if)# ip tcp adjust-mss 1452
Cust1(config-if)# end

Reflexión

Explique por qué es necesario ajustar el tamaño del segmento TCP para el PPPoE.

Las respuestas pueden variar. El tamaño predeterminado de segmento para Ethernet es 1500. La información del encabezado utiliza 40 bytes del segmento y deja 1460 bytes para la carga (datos). El PPPoE requiere 8 bytes adicionales para el encabezado, por lo que la carga se debe reducir en 8 bytes para adaptarse al encabezado del PPPoE, lo que reduce el tamaño óptimo del segmento máximo a 1452 bytes.

Tabla de resumen de interfaces de router

Resumen de interfaces de router
Modelo de router Interfaz Ethernet 1 Interfaz Ethernet 2 Interfaz serial 1 Interfaz serial 2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Nota: Para conocer la configuración del router, observe las interfaces a fin de identificar el tipo de router y cuántas interfaces tiene. No existe una forma eficaz de hacer una lista de todas las combinaciones de configuraciones para cada clase de router. En esta tabla se incluyen los identificadores para las posibles combinaciones de interfaces Ethernet y seriales en el dispositivo. En esta tabla, no se incluye ningún otro tipo de interfaz, si bien puede haber interfaces de otro tipo en un router determinado. La interfaz BRI ISDN es un ejemplo. La cadena entre paréntesis es la abreviatura legal que se puede utilizar en un comando de Cisco IOS para representar la interfaz.

Configuraciones de dispositivos

  • Router Cust1
  • Router ISP
Cust1# show run
Building configuration...
Current configuration : 1433 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cust1
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname Cust1
ppp chap password 0 ciscopppoe
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
control-plane
!
banner motd ^C
Unauthorized Access Prohibited.
^C
!
line con 0
password 7 14141B180F0B
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 05080F1C2243
login
transport input all
!
scheduler allocate 20000 1000
!
end
ISP# show run
Building configuration...
Current configuration : 1485 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
ciscopppoe de la contraseña 0 de nombre de usuario Cust1
!
bba-group pppoe global
virtual-template 1
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable group global
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Virtual-Template1
ip address 10.0.0.254 255.255.255.0
mtu 1492
peer default ip address pool PPPoEPOOL
ppp authentication chap callin
!
ip local pool PPPoEPOOL 10.0.0.1 10.0.0.10
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
banner motd ^C
Unauthorized Access Prohibited.
^C
!
line con 0
password 7 14141B180F0B
logging synchronous
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 05080F1C2243
login
transport input all
!
scheduler allocate 20000 1000
!
end

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x