3.5.3.5 Práctica de laboratorio: Configuración y comprobación de eBGP Respuestas

Última actualización: septiembre 16, 2022

3.5.3.5 Práctica de laboratorio: Configuración y comprobación de eBGP (versión para el instructor)

Nota para el instructor: el color de fuente rojo o las partes resaltadas en gris indican texto que aparece en la copia del instructor solamente.

Topología

Tabla de asignación de direcciones

Dispositivo Interfaz Dirección IP Máscara de subred
R1 S0/0/0 (DCE) 198.133.219.1 255.255.255.248
R2 S0/0/0 198.133.219.2 255.255.255.248
S0/0/1 (DCE) 209.165.200.2 255.255.255.252
ISP-1 S0/0/1 209.165.200.1 255.255.255.252
Servidor web 10.10.10.10 255.255.255.255

Objetivos

Parte 1: armar la red y configurar los parámetros básicos de los dispositivos
Parte 2: Configurar eBGP en el R1
Parte 3: Comprobar la configuración de eBGP

Aspectos básicos/situación

En esta actividad de laboratorio, configurará eBGP para la empresa. El ISP proporcionará la ruta predeterminada a Internet. Una vez que se haya completado la configuración, utilizará diversos comandos show para comprobar que la configuración de eBGP funcione como se espera.

Recursos necesarios

• 3 routers (Cisco 1941 con Cisco IOS versión 15.2[4])M3, imagen universal o similar)
• Cables de consola para configurar los dispositivos con Cisco IOS mediante los puertos de consola
• Cables de serie, como se muestran en la topología

Parte 1: Armar la red y configurar los ajustes básicos de los dispositivos

En la parte 1, establecerá la topología de la red y configurará los parámetros básicos en los routers R1 y R2. También copiará la configuración provista del ISP-1 a dicho router.

Paso 1: Realizar el cableado de red tal como se muestra en la topología

Paso 2: Iniciar y volver a cargar los dispositivos de red según sea necesario.

Paso 3: Configurar los parámetros básicos en el R1 y R2.

a. Deshabilite la búsqueda DNS para evitar que el router intente traducir los comandos incorrectamente introducidos como si fueran nombres de host.

b. Configure los nombres de host de acuerdo con la topología.

c. Configure las interfaces según la tabla de asignación de direcciones.

d. Guarde la configuración en ejecución en el archivo de configuración de inicio.

Paso 4: Copiar la configuración al ISP-1.

Copie y pegue la siguiente configuración en ISP-1.

hostname ISP-1
no ip domain-lookup
interface Loopback0
ip address 10.10.10.10 255.255.255.255
interface Serial0/0/1
ip address 209.165.200.1 255.255.255.252
no shut
ip route 0.0.0.0 0.0.0.0 lo0
router bgp 65001
bgp log-neighbor-changes
network 0.0.0.0
neighbor 209.165.200.2 remote-as 65000
end

Parte 2: Configurar el eBGP en el R2

Configure el R2 para que se convierta en un par de eBGP con el ISP-1. Consulte la topología para obtener la información del número de sistema autónomo (AS, autonomous system) de BGP.

Paso 1: Activar BGP e identificar el número de AS de la empresa.

R2(config)# router bgp 65000

Paso 2: Utilizar el comando neighbor para identificar el ISP-1 como el par de BGP.

R2(config-router)# neighbor 209.165.200.1 remote-as 65001

Paso 3: Agregar la red de la empresa a la tabla de BGP para que se anuncie al ISP-1.

R2(config-router)# network 198.133.219.0 mask 255.255.255.248

Parte 3: Verificar la configuración de eBGP

En la parte 3, utilice los comandos de verificaciones del BGP para comprobar que la configuración del BGP funcione como se espera.

Paso 1: Visualice la tabla de routing IPV4 en el R2.

R2# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route  
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       a - application route  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 209.165.200.1 to network 0.0.0.0  
  
B*    0.0.0.0/0 [20/0] via 209.165.200.1, 00:00:07  
      198.133.219.0/24 is variably subnetted, 2 subnets, 2 masks  
C        198.133.219.0/29 is directly connected, Serial0/0/0  
L        198.133.219.2/32 is directly connected, Serial0/0/0  
      209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks  
C        209.165.200.0/30 is directly connected, Serial0/0/1  
L        209.165.200.2/32 is directly connected, Serial0/0/1

Paso 2: Visualice la tabla del BGP en el R2.

R2# show ip bgp
BGP table version is 4, local router ID is 209.165.200.2  
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,   
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,   
              x best-external, a additional-path, c RIB-compressed,   
Origin codes: i - IGP, e - EGP, ? - incomplete  
RPKI validation codes: V valid, I invalid, N Not found  
  
     Network          Next Hop            Metric LocPrf Weight Path  
 *>  0.0.0.0          209.165.200.1            0             0 65001 i  
 *>  198.133.219.0/29 0.0.0.0                  0         32768 i

Paso 3: Visualice el estado de conexión del BGP en el R2.

R2# show ip bgp summary
BGP router identifier 209.165.200.2, local AS number 65000
BGP table version is 4, main routing table version 4
2 network entries using 288 bytes of memory
2 path entries using 160 bytes of memory
2/2 BGP path/bestpath attribute entries using 320 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 792 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd  
209.165.200.1   4        65001      12      11        4    0    0 00:06:56        1

Paso 4: Visualice la tabla de routing IPV4 en el ISP-1.

Compruebe que la red 198.133.218.0/29 se anuncie al router ISP-1.

ISP-1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP  
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area   
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2  
       E1 - OSPF external type 1, E2 - OSPF external type 2  
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2  
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP  
       a - application route  
       + - replicated route, % - next hop override  
  
Gateway of last resort is 0.0.0.0 to network 0.0.0.0  
  
S*    0.0.0.0/0 is directly connected, Loopback0  
      10.0.0.0/32 is subnetted, 1 subnets  
C        10.10.10.10 is directly connected, Loopback0  
      198.133.219.0/29 is subnetted, 1 subnets  
B        198.133.219.0 [20/0] via 209.165.200.2, 00:00:25  
      209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks  
C        209.165.200.0/30 is directly connected, Serial0/0/1  
L        209.165.200.1/32 is directly connected, Serial0/0/1

Emita un comando ping al servidor web desde el R1. ¿Fueron correctos los pings?
Sí, los pings deberían haber sido correctos.

Reflexión

La topología que se utiliza en esta actividad de laboratorio se creó para demostrar cómo configurar el protocolo de routing BGP. Sin embargo, el protocolo BGP por lo general no se configuraría para una topología como esta en el mundo real. Explique.

Las respuestas pueden variar. BGP no suele ser necesario para una red de única localización. El ISP proporcionaría el rango de direcciones IP de una subred IP para que la empresa lo utilice para el acceso a Internet y el ISP sería responsable del routing del tráfico de la empresa al R2. Entonces, solo el ISP debería tener el BGP configurado.

Tabla de resumen de interfaces de router

Resumen de interfaces de router
Modelo de router Interfaz Ethernet 1 Interfaz Ethernet 2 Interfaz serial 1 Interfaz serial 2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Nota: Para conocer la configuración del router, observe las interfaces a fin de identificar el tipo de router y cuántas interfaces tiene. No existe una forma eficaz de hacer una lista de todas las combinaciones de configuraciones para cada clase de router. En esta tabla se incluyen los identificadores para las posibles combinaciones de interfaces Ethernet y seriales en el dispositivo. En esta tabla, no se incluye ningún otro tipo de interfaz, si bien puede haber interfaces de otro tipo en un router determinado. La interfaz BRI ISDN es un ejemplo. La cadena entre paréntesis es la abreviatura legal que se puede utilizar en un comando de Cisco IOS para representar la interfaz.

Configuraciones de dispositivos

  • Router R1
  • Router R2
  • Router ISP-1
R1# show run
Building configuration...

Current configuration : 1334 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 198.133.219.1 255.255.255.248
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
línea con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
R2# show run
Building configuration...

Current configuration : 1409 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 198.133.219.2 255.255.255.248
!
interface Serial0/0/1
ip address 209.165.200.2 255.255.255.252
clock rate 2000000
!
router bgp 65000
bgp log-neighbor-changes
network 198.233.219.0 mask 255.255.255.248
neighbor 209.165.200.1 remote-as 65001
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
línea con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
ISP-1# show run
Building configuration...

Current configuration : 1535 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP-1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 15
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
redundancy
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
ip address 209.165.200.1 255.255.255.252
!
router bgp 65001
bgp log-neighbor-changes
network 0.0.0.0
neighbor 209.165.200.2 remote-as 65000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Loopback0
!
control-plane
!
línea con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

 

Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x