8.1.4.8 Práctica de laboratorio: Diseño e implementación de un esquema de direccionamiento IPv4 dividido en subredes Respuestas

Última actualización: septiembre 16, 2022

8.1.4.8 Práctica de laboratorio: Diseño e implementación de un esquema de direccionamiento IPv4 dividido en subredes (versión para el instructor)

Nota para el instructor: el color de fuente rojo o las partes resaltadas en gris indican texto que aparece en la copia del instructor solamente.

Topología

Tabla de direccionamiento

Dispositivo Interfaz Dirección IP Máscara de subred Gateway predeterminado
R1 G0/0 No aplicable
G0/1 No aplicable
Lo0 No aplicable
Lo1 No aplicable
S1 VLAN 1 No aplicable No aplicable No aplicable
PC-A NIC
PC-B NIC

Objetivos

Parte 1: Diseñar un esquema de división en subredes

  • Crear un esquema de división en subredes que cumpla con la cantidad requerida de subredes y direcciones de host.
  • Completar el diagrama para mostrar dónde se aplicarán las direcciones IP de host.

Parte 2: Configurar los dispositivos

  • Asignar una dirección IP, una máscara de subred y un gateway predeterminado a las PC.
  • Configurar las interfaces Gigabit Ethernet del router con una dirección IP y una máscara de subred.
  • Crear dos interfaces loopback en el router y configurar cada una con una dirección IP y una máscara de subred.

Parte 3: Probar la red y resolver los problemas encontrados

  • Verificar y resolver problemas de conectividad de red mediante el comando ping.

Información básica/Situación

En esta práctica de laboratorio, a partir de una sola dirección de red y una máscara de red, dividirá la red en varias subredes. El esquema de división en subredes se basará en la cantidad de equipos host necesarios en cada subred, así como en otras consideraciones de redes, como la futura expansión de hosts de la red.

Después de crear un esquema de división en subredes y completar el diagrama de red con las direcciones IP de hosts e interfaces, configurará las PC host y las interfaces del router, incluidas las interfaces loopback. Las interfaces loopback se crean para simular LAN adicionales conectadas al router R1.

Una vez configurados los dispositivos de red y las PC host, utilizará el comando ping para probar la conectividad de red.

En esta práctica de laboratorio, se proporciona la ayuda mínima relativa a los comandos reales necesarios para configurar el router. Sin embargo, los comandos requeridos se proporcionan en el apéndice A. Ponga a prueba su conocimiento intentando configurar los dispositivos sin consultar el apéndice.

Nota: los routers que se utilizan en las prácticas de laboratorio de CCNA son routers de servicios integrados (ISR, Integrated Services Routers) Cisco 1941 con Cisco IOS versión 15.2(4)M3 (imagen universalk9). Los switches que se utilizan son Cisco Catalyst 2960s con Cisco IOS versión 15.0(2) (imagen de lanbasek9). Pueden utilizarse otros routers, switches y versiones de Cisco IOS. Según el modelo y la versión de Cisco IOS, los comandos disponibles y los resultados obtenidos pueden diferir de los que se muestran en las prácticas de laboratorio. Consulte la tabla Resumen de interfaces del router al final de la práctica de laboratorio para obtener los identificadores de interfaz correctos.

Nota: asegúrese de que los routers y los switches se hayan borrado y no tengan configuraciones de inicio. Si no está seguro, consulte con el instructor.

Nota para el instructor: consulte el Manual de prácticas de laboratorio para el instructor a fin de conocer los procedimientos para inicializar y volver a cargar los dispositivos.

Recursos necesarios

  • 1 router (Cisco 1941 con Cisco IOS, versión 15.2(4)M3, imagen universal o similar)
  • 1 switch (Cisco 2960 con Cisco IOS, versión 15.0(2), imagen lanbasek9 o similar)
  • 2 PC (Windows 7, Vista o XP con un programa de emulación de terminal, por ejemplo, Tera Term)
  • Cables de consola para configurar los dispositivos Cisco IOS mediante los puertos de consola
  • Cables Ethernet, como se muestra en la topología.

Nota: las interfaces Gigabit Ethernet en los routers Cisco 1941 cuentan con detección automática. Se puede usar un cable directo de Ethernet entre el router y la PC-B. Si utiliza otro modelo de router Cisco, puede ser necesario usar un cable cruzado Ethernet.

Parte 1: Diseñar un esquema de división en subredes

Paso 1: Crear un esquema de división en subredes que cumpla con la cantidad requerida de subredes y de direcciones de host

En esta situación, usted es un administrador de red para una pequeña subdivisión de una compañía más grande. Debe crear varias subredes a partir del espacio de direcciones de red 192.168.0.0/24 para cumplir los siguientes requisitos:

  • La primera subred es la red de los empleados. Necesita un mínimo de 25 direcciones IP de host.
  • La segunda subred es la red de administración. Necesita un mínimo de 10 direcciones IP.
  • La tercera y la cuarta subredes están reservadas como redes virtuales en las interfaces virtuales del router loopback 0 y loopback 1. Estas interfaces virtuales del router simulan LAN conectadas al R1.
  • También necesita dos subredes adicionales sin utilizar para la futura expansión de la red.

Nota: no se usarán máscaras de subred de longitud variable. Todas las máscaras de subred de los dispositivos tendrán la misma longitud.

Responda las siguientes preguntas para poder crear un esquema de división en subredes que cumpla con los requisitos de red mencionados:

1) ¿Cuántas direcciones de host se necesitan en la subred requerida más grande? ___________25

2) ¿Cuál es la cantidad mínima de subredes necesaria? ______________________________
Los requisitos arriba mencionados especifican dos redes de la compañía más dos redes virtuales de loopback y dos redes adicionales para expansión futura. Entonces, la respuesta es un mínimo de seis redes.

3) La red que se le asignó para la división en subredes es 192.168.0.0/24. ¿Cómo es la máscara de subred /24 en formato binario?
______________________________________________
1111111.11111111.11111111.00000000

4) La máscara de subred consta de dos partes: la porción de red y la porción de host. En sistema binario, esto se representa mediante unos y ceros en la máscara de subred.

En la máscara de red, ¿qué representan los unos? _____________________________________
Los unos representan la porción de red.

En la máscara de red, ¿qué representan los ceros? _____________________________________
Los ceros representan la porción de host.

5) Para dividir una red en subredes, los bits de la porción de host de la máscara de red original cambian por bits de subred. La cantidad de bits de subred define la cantidad de subredes. Dada cada una de las posibles máscaras de subred presentadas a continuación en formato binario, ¿cuántas subredes y cuántos hosts se crean en cada ejemplo?

Sugerencia: recuerde que la cantidad de bits de host (en potencia de 2) define la cantidad de hosts por subred (menos 2), y que la cantidad de bits de subred (en potencia de 2) define la cantidad de subredes. Los bits de subred (representados en negrita) son los bits que se tomaron prestados más allá de la máscara de red original /24. /24 es la notación de prefijo de barra y corresponde a la máscara decimal punteada 255.255.255.0.

(/25) 11111111.11111111.11111111.10000000

Equivalente decimal punteado de la máscara de subred: _____________________________
255.255.255.128

¿Cantidad de subredes? _________ ¿Cantidad de hosts? ___________
Dos subredes (21) y 128 hosts (27) – 2 = 126 hosts por subred

(/26) 11111111.11111111.11111111.11000000

Equivalente decimal punteado de la máscara de subred: ___________________________
255.255.255.192

¿Cantidad de subredes? ________ ¿Cantidad de hosts? _____________
Cuatro subredes (22) y 64 hosts (26) – 2 = 62 hosts por subred

(/27) 11111111.11111111.11111111.11100000

Equivalente decimal punteado de la máscara de subred: ____________________________
255.255.255.224

¿Cantidad de subredes? _________ ¿Cantidad de hosts? _________
Ocho subredes (23) y 32 hosts (25) – 2 = 30 hosts por subred

(/28) 11111111.11111111.11111111.11110000

Equivalente decimal punteado de la máscara de subred: ___________________________
255.255.255.240

¿Cantidad de subredes? _________ ¿Cantidad de hosts? _______
Dieciséis subredes (24) y 16 hosts (24) – 2 = 14 hosts por subred

(/29) 11111111.11111111.11111111.11111000

Equivalente decimal punteado de la máscara de subred: ____________________________
255.255.255.248

¿Cantidad de subredes? __________ ¿Cantidad de hosts? _________
Treinta y dos subredes (25) y 8 hosts (23) – 2 = 6 hosts por subred

(/30) 11111111.11111111.11111111.11111100

Equivalente decimal punteado de la máscara de subred: ___________________________
255.255.255.252

¿Cantidad de subredes? __________ ¿Cantidad de hosts? ______________
Sesenta y cuatro subredes (26) y 4 hosts (22) – 2 = 2 hosts por subred

6) Sobre la base de sus respuestas, ¿qué máscaras de subred cumplen con la cantidad mínima requerida de direcciones de host?
______________________________________________
/25, /26, /27

7) Sobre la base de sus respuestas, ¿qué máscaras de subred cumplen con la cantidad mínima requerida de subredes?
_______________________________________________
/27, /28, /29, /30 darán la cantidad requerida de subredes.

8) Sobre la base de sus respuestas, ¿qué máscara de subred cumple con la cantidad mínima requerida de hosts y también con la cantidad mínima requerida de subredes?
_______________________________________________
/27 le dará ocho subredes, que es mayor que la cantidad mínima requerida de cinco, y 30 hosts por subred, que es mayor que los 25 hosts requeridos para la primera subred.

9) Cuando haya determinado qué máscara de subred cumple con todos los requisitos de red mencionados, derivará cada una de las subredes a partir de la dirección de red original. Indique las subredes desde la primera hasta la última a continuación. Recuerde que la primera subred es 192.168.0.0, con la máscara de subred recién adquirida.

Dirección de subred / PrefijoMáscara de subred (decimal punteada)
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
___________________ / ____ __________________________
192.168.0.0, 192.168.0.32, 192.168.0.64, 192.168.0.96, 192.168.0.128, 192.168.0.160, 192.168.0.192, 192.168.0.224. En todos los casos, el prefijo es /27. En todos los casos, la máscara de subred es 255.255.255.224 (decimal punteada).

Paso 2: Completar el diagrama para mostrar dónde se aplicarán las direcciones IP de host

En las líneas siguientes, complete las direcciones IP y las máscaras de subred en notación de prefijo de barra. En el router, utilice la primera dirección utilizable en cada subred para cada una de las interfaces: Gigabit Ethernet 0/0, Gigabit Ethernet 0/1, loopback 0 y loopback 1. Complete una dirección IP para la PC-A y la PC-B. También introduzca esta información en la tabla de direccionamiento de la página 1.

Las direcciones de las interfaces Gigabit Ethernet 0/0, Gigabit Ethernet 0/1, loopback 0 y loopback 1 del router serían: 192.168.0.1/27, 192.168.0.33/27, 192.168.0.65/27, 192.168.0.97/27. Si la interfaz Gigabit 0/0 es la primera subred, la dirección IP de la PC-B será un número entre 192.168.0.2 y 192.168.0.30. Si la interfaz Gigabit 0/1 es la segunda subred, la dirección IP de la PC-A será un número entre 192.168.0.34 y 192.168.0.62.

Parte 2: Configurar los dispositivos

En la parte 2, establecerá la topología de la red y configurará los parámetros básicos en las PC y el router, como las direcciones IP de la interfaz Gigabit Ethernet del router y las direcciones IP, las máscaras de subred y los gateways predeterminados de las PC. Consulte la tabla de direccionamiento para obtener los nombres e información de dirección de los dispositivos.

Nota: en el apéndice A, se proporcionan detalles de configuración para los pasos de la parte 2. Antes de consultar el apéndice A, intente completar la parte 2.

Paso 1: Configurar el router.

a. Ingrese al modo EXEC privilegiado y, luego, al modo de configuración global.

b. Asigne R1 como nombre de host para el router.

c. Configure las interfaces G0/0 y G0/1 con direcciones IP y máscaras de subred y, luego, habilítelas.

d. Las interfaces loopback se crean para simular LAN adicionales en el router R1. Configure las interfaces loopback con direcciones IP y máscaras de subred. Una vez que se crean, las interfaces loopback se habilitan de manera predeterminada. (Para crear las direcciones de loopback, introduzca el comando interface loopback 0 en el modo de configuración global).

Nota: si lo desea, puede crear varios loopbacks adicionales para probar con diferentes esquemas de direccionamiento.

e. Guarde la configuración en ejecución en el archivo de configuración de inicio.

Paso 2: Configure las interfaces de la PC.

a. Configure la dirección IP, la máscara de subred y las configuraciones de gateway predeterminado en la PC-A.

b. Configure la dirección IP, la máscara de subred y las configuraciones de gateway predeterminado en la PC-B.

Parte 3: Probar la red y resolver los problemas encontrados

En la parte 3, utilizará el comando ping para probar la conectividad de red.

a. Pruebe si la PC-A puede comunicarse con el gateway predeterminado. En la PC-A, abra un símbolo del sistema y haga ping a la dirección IP de la interfaz Gigabit Ethernet 0/1 del router. ¿Obtiene una respuesta?
_________________
Si la interfaz de la PC y la interfaz del router se configuraron correctamente, el ping debe ser correcto. Si no es así, revise los puntos “d” y “e” a continuación.

b. Pruebe si la PC-B puede comunicarse con el gateway predeterminado. En la PC-B, abra un símbolo del sistema y haga ping a la dirección IP de la interfaz Gigabit Ethernet 0/0 del router. ¿Obtiene una respuesta?
________________
Si la interfaz de la PC y la interfaz del router se configuraron correctamente, el ping debe ser correcto. Si no es así, revise los puntos “d” y “e” a continuación.

c. Pruebe si la PC-A puede comunicarse con la PC-B. En la PC-A, abra un símbolo del sistema y haga ping a la dirección IP de la PC-B. ¿Obtiene una respuesta? _________________
Si las PC y las interfaces Gigabit Ethernet del router se configuraron correctamente, los pings deben realizarse de manera correcta. Si no es así, revise los puntos “d” y “e” a continuación.

d. Si alguna de sus respuestas a las preguntas anteriores fue negativa, debe revisar todas las configuraciones de dirección IP y máscara de subred, y asegurarse de que los gateways predeterminados estén configurados correctamente en la PC-A y la PC-B.

e. Si verifica que todas las configuraciones son correctas y aún no puede hacer ping correctamente, hay algunos otros factores que pueden bloquear los pings de ICMP. En Windows, en la PC-A y la PC-B, asegúrese de que el Firewall de Windows esté desactivado para las redes de trabajo, doméstica y pública.

f. Experimente configurando a propósito la dirección del gateway de manera incorrecta en la PC-A como 10.0.0.1. ¿Qué sucede cuando intenta hacer ping de la PC-B a la PC-A? ¿Recibe una respuesta?
__________________________________________________
Con configuraciones incorrectas deliberadas, la respuesta debe ser no.

Reflexión

1. Dividir una red grande en subredes más pequeñas brinda mayor flexibilidad y seguridad en el diseño de redes. Sin embargo, ¿cuáles piensa que son algunas en las desventajas cuando las subredes están limitadas a tener el mismo tamaño?
________________________________________________________
Las respuestas varían. Los estudiantes pueden sugerir que, debido a que algunas subredes requieren muchas direcciones IP y otras requieren solo unas pocas, tener todas las subredes del mismo tamaño no es la forma más eficaz de dividir las subredes.

2. ¿Por qué piensa que la dirección IP del gateway o del router es generalmente la primera dirección IP utilizable en la red?
________________________________________________________
Las respuestas varían. Puede sugerirse que se debe a que el router o el gateway son como una puerta a la red y, por lo tanto, es lógico que la dirección esté al comienzo de la red. Sin embargo, no es más que una convención y, por lo tanto, no es obligatorio que el router tenga la primera o la última dirección en la red.

Tabla de resumen de interfaces del router

Resumen de interfaces del router
Modelo de router Interfaz Ethernet #1 Interfaz Ethernet #2 Interfaz serial #1 Interfaz serial #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Nota: para conocer la configuración del router, observe las interfaces a fin de identificar el tipo de router y cuántas interfaces tiene. No existe una forma eficaz de confeccionar una lista de todas las combinaciones de configuraciones para cada clase de router. En esta tabla, se incluyen los identificadores para las posibles combinaciones de interfaces Ethernet y seriales en el dispositivo. En esta tabla, no se incluye ningún otro tipo de interfaz, si bien puede hacer interfaces de otro tipo en un router determinado. La interfaz BRI ISDN es un ejemplo. La cadena entre paréntesis es la abreviatura legal que se puede utilizar en los comandos de Cisco IOS para representar la interfaz.

Apéndice A: Detalles de configuración para los pasos de la parte 2

Paso 1: Configurar el router.

a. Acceda al router mediante el puerto de consola e ingrese al modo EXEC privilegiado.

Router> enable
Router#

b. Entre al modo de configuración.

Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

c. Asigne un nombre de dispositivo al router.

Router(config)# hostname R1
R1(config)#

d. Configure las interfaces G0/0 y G0/1 con direcciones IP y máscaras de subred, y habilítelas.

R1(config)# interface g0/0
R1(config-if)# ip address  
R1(config-if)# no shutdown
R1(config-if)# interface g0/1
R1(config-if)# ip address  
R1(config-if)# no shutdown

e. Las interfaces loopback se crean para simular LAN adicionales fuera del router R1. Configure las interfaces loopback con direcciones IP y máscaras de subred. Cuando se crean, las interfaces loopback se habilitan de manera predeterminada.

R1(config)# interface loopback 0
R1(config-if)# ip address  
R1(config-if)# interface loopback 1
R1(config-if)# ip address  
R1(config-if)# end

f. Guarde la configuración en ejecución en el archivo de configuración de inicio.

R1# copy running-config startup-config

Paso 2: Configure las interfaces de la PC.

a. Configure la dirección IP, la máscara de subred y las configuraciones de gateway predeterminado en la PC-A.

b. Configure la dirección IP, la máscara de subred y las configuraciones de gateway predeterminado en la PC-B.

Configuraciones de dispositivos

Router R1 

R1#show run
Building configuration...

Current configuration : 1518 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
no ipv6 cef
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
!
!
ip cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
!
redundancy
!
!
!
!
interface Loopback0
ip address 192.168.0.65 255.255.255.224
!
interface Loopback1
ip address 192.168.0.97 255.255.255.224
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.0.1 255.255.255.224
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.0.33 255.255.255.224
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x