8.2.1.5 Práctica de laboratorio: Diseño e implementación de un esquema de direccionamiento VLSM Respuestas

Última actualización: septiembre 16, 2022

8.2.1.5 Práctica de laboratorio: Diseño e implementación de un esquema de direccionamiento VLSM (versión para el instructor)

Nota para el instructor: el color de fuente rojo o las partes resaltadas en gris indican texto que aparece en la copia del instructor solamente.

Topología

Objetivos

Parte 1: Examinar los requisitos de la red
Parte 2: Diseñar el esquema de direcciones VLSM
Parte 3: Cablear y configurar la red IPv4

Información básica/Situación

La máscara de subred de longitud variable (VLSM) se diseñó para evitar el desperdicio de direcciones IP. Con VLSM, una red se divide en subredes y luego se vuelve a dividir en subredes. Este proceso se puede repetir varias veces para crear subredes de diversos tamaños según la cantidad de hosts necesarios en cada subred. El uso eficaz de VLSM requiere la planificación de direcciones.

En esta práctica de laboratorio, utilice la dirección de red 172.16.128.0/17 para desarrollar un esquema de direcciones para la red que se muestra en el diagrama de topología. VLSM se utiliza para cumplir con los requisitos de direccionamiento IPv4. Después de diseñar el esquema de direcciones VLSM, configurará las interfaces en los routers con la información de direcciones IP correspondiente.

Nota: los routers que se utilizan en las prácticas de laboratorio de CCNA son routers de servicios integrados (ISR, Integrated Services Routers) Cisco 1941 con Cisco IOS versión 15.2(4)M3 (imagen universalk9). Se pueden utilizar otros routers y otras versiones de Cisco IOS. Según el modelo y la versión de Cisco IOS, los comandos disponibles y los resultados obtenidos pueden diferir de los que se muestran en las prácticas de laboratorio. Consulte la tabla Resumen de interfaces del router que se encuentra al final de esta práctica de laboratorio para obtener los identificadores de interfaz correctos.

Nota: asegúrese de que los routers se hayan eliminado y no tengan configuraciones de inicio. Si no está seguro, consulte con el instructor.

Nota para el instructor: consulte el Manual de prácticas de laboratorio para el instructor a fin de conocer los procedimientos para inicializar y volver a cargar los dispositivos.

Si el tiempo es un problema, esta práctica de laboratorio se puede realizar en varias sesiones. Las partes 1 y 2 se resuelven de manera escrita, por lo que pueden asignarse como tarea para el hogar. La parte 3 es práctica y requiere equipos para prácticas de laboratorio.

Cabe mencionar a los estudiantes que, como administrador de red, no tendría una sola red con más de 1000 hosts, sino que los dividiría en una red de producción.

Recursos necesarios

  • 3 routers (Cisco 1941 con software Cisco IOS, versión 15.2(4)M3, imagen universal o comparable)
  • 1 PC (con programa de emulación de terminal, como Tera Term, para configurar los routers)
  • Cable de consola para configurar los dispositivos Cisco IOS a través de los puertos de consola
  • Cables Ethernet (optativos) y seriales, según se muestra en la topología
  • Calculadora de Windows (optativo)

Parte 1: Examinar los requisitos de la red

En la parte 1, examinará los requisitos de la red para desarrollar un esquema de direcciones VLSM para la red que se muestra en el diagrama de topología utilizando la dirección de red 172.16.128.0/17.

Nota: para obtener ayuda con los cálculos, puede utilizar la aplicación de calculadora de Windows y la calculadora de subredes IP de www.ipcalc.org.

Paso 1: Determinar cuántas direcciones de host y cuántas subredes hay disponibles

¿Cuántas direcciones de host hay disponibles en una red /17? _______32,766

¿Cuál es la cantidad total de direcciones de host necesarias en el diagrama de topología? _______31,506

¿Cuántas subredes se necesitan en la topología de la red? _____9

Paso 2: Determinar la subred más grande

¿Cuál es la descripción de la subred (p. ej., enlace BR1 G0/1 LAN o BR1-HQ WAN)? ____________HQ G0/0 LAN

¿Cuántas direcciones IP se requieren en la subred más grande? _________16,000

¿Qué máscara de subred puede admitir esa cantidad de direcciones de host?
___________________/18 o 255.255.192.0

¿Cuántas direcciones de host totales puede admitir esa máscara de subred? _______16,382

¿Puede dividir la dirección de red 172.16.128.0/17 en subredes para admitir esta subred? ____

¿Cuáles son las dos direcciones de red que derivarían de esta división en subredes?
___________________172.16.128.0/18
___________________172.16.192.0/18

Utilice la primera dirección de red para esta subred.

Paso 3: Determinar la segunda subred más grande

¿Cuál es la descripción de la subred? ______________HQ G0/1 LAN

¿Cuántas direcciones IP se requieren para la segunda subred más grande? ____8,000

¿Qué máscara de subred puede admitir esa cantidad de direcciones de host?
_____________/19 o 255.255.224.0

¿Cuántas direcciones de host totales puede admitir esa máscara de subred? _________8,190

¿Puede volver a dividir la subred restante en subredes y aún admitir esta subred? _____

¿Cuáles son las dos direcciones de red que derivarían de esta división en subredes?
___________________172.16.192.0/19
___________________172.16.224.0/19

Utilice la primera dirección de red para esta subred.

Paso 4: Determine la siguiente subred más grande.

¿Cuál es la descripción de la subred? ______________BR1 G0/1 LAN

¿Cuántas direcciones IP se requieren para la siguiente subred más grande? ____4,000

¿Qué máscara de subred puede admitir esa cantidad de direcciones de host?
_______________/20 o 255.255.240.0

¿Cuántas direcciones de host totales puede admitir esa máscara de subred? ________4,094

¿Puede volver a dividir la subred restante en subredes y aún admitir esta subred? ____

¿Cuáles son las dos direcciones de red que derivarían de esta división en subredes?
__________________172.16.224.0/20
__________________172.16.240.0/20

Utilice la primera dirección de red para esta subred.

Paso 5: Determine la siguiente subred más grande.

¿Cuál es la descripción de la subred? _________________BR1 G0/0 LAN

¿Cuántas direcciones IP se requieren para la siguiente subred más grande? _____2,000

¿Qué máscara de subred puede admitir esa cantidad de direcciones de host?
______________/21 o 255.255.248.0

¿Cuántas direcciones de host totales puede admitir esa máscara de subred? ________2,046

¿Puede volver a dividir la subred restante en subredes y aún admitir esta subred? _____

¿Cuáles son las dos direcciones de red que derivarían de esta división en subredes?
___________________172.16.240.0/21
___________________172.16.248.0/21

Utilice la primera dirección de red para esta subred.

Paso 6: Determine la siguiente subred más grande.

¿Cuál es la descripción de la subred? _______________BR2 G0/1 LAN

¿Cuántas direcciones IP se requieren para la siguiente subred más grande? _____1,000

¿Qué máscara de subred puede admitir esa cantidad de direcciones de host?
_______________/22 o 255.255.252.0

¿Cuántas direcciones de host totales puede admitir esa máscara de subred? _______1,022

¿Puede volver a dividir la subred restante en subredes y aún admitir esta subred? _____

¿Cuáles son las dos direcciones de red que derivarían de esta división en subredes?
__________________172.16.248.0/22
__________________172.16.252.0/22

Utilice la primera dirección de red para esta subred.

Paso 7: Determine la siguiente subred más grande.

¿Cuál es la descripción de la subred? _____________BR2 G0/0 LAN

¿Cuántas direcciones IP se requieren para la siguiente subred más grande? _____500

¿Qué máscara de subred puede admitir esa cantidad de direcciones de host?
_______________/23 o 255.255.254.0

¿Cuántas direcciones de host totales puede admitir esa máscara de subred? ________510

¿Puede volver a dividir la subred restante en subredes y aún admitir esta subred? _____

¿Cuáles son las dos direcciones de red que derivarían de esta división en subredes?
__________________172.16.252.0/23
__________________172.16.254.0/23

Utilice la primera dirección de red para esta subred.

Paso 8: Determinar las subredes necesarias para admitir los enlaces seriales

¿Cuántas direcciones de host se requieren para cada enlace serial de subred? ____2

¿Qué máscara de subred puede admitir esa cantidad de direcciones de host?
________________/30 o 255.255.255.252

a. Continúe subdividiendo la primera subred de cada subred nueva hasta que tenga cuatro subredes /30.
Escriba las tres primeras direcciones de red de estas subredes /30 a continuación.
________________172.16.254.0/30
________________172.16.254.4/30
________________172.16.254.8/30

b. Introduzca las descripciones de subred para estas tres subredes a continuación.
_______________________Enlace serial HQ – BR1
_______________________Enlace serial HQ – BR2
_______________________Enlace serial BR1 – BR2

Parte 2: Diseñar el esquema de direcciones VLSM

Paso 1: Calcular la información de subred

Utilice la información que obtuvo en la parte 1 para completar la siguiente tabla.

Descripción de la subred Cantidad de hosts necesarios Dirección de red /CIDR Primera dirección de host Dirección de broadcast
HQ G0/0 16 000 172.16.128.0/18 172.16.128.1 172.16.191.255
HQ G0/1 8 000 172.16.192.0/19 172.16.192.1 172.16.223.255
BR1 G0/1 4 000 172.16.224.0/20 172.16.224.1 172.16.239.255
BR1 G0/0 2 000 172.16.240.0/21 172.16.240.1 172.16.247.255
BR2 G0/1 1000 172.16.248.0/22 172.16.248.1 172.16.251.255
BR2 G0/0 500 172.16.252.0/23 172.16.252.1 172.16.253.255
HQ S0/0/0 – BR1 S0/0/1 2 172.16.254.0/30 172.16.254.1 172.16.254.3
HQ S0/0/1 – BR2 S0/0/1 2 172.16.254.4/30 172.16.254.5 172.16.254.7
BR1 S0/0/1 – BR2 S0/0/0 2 172.16.254.8/30 172.16.254.9 172.168.254.11

Paso 2: Completar la tabla de direcciones de interfaces de dispositivos

Asigne la primera dirección de host en la subred a las interfaces Ethernet. A HQ se le debe asignar la primera dirección de host en los enlaces seriales a BR1 y BR2. A BR1 se le debe asignar la primera dirección de host para el enlace serial a BR2.

Dispositivo Interfaz Dirección IP Máscara de
subred
Interfaz de
dispositivo
HQ G0/0 172.16.128.1 255.255.192.0 LAN de 16 000 hosts
G0/1 172.16.192.1 255.255.224.0 LAN de 8000 hosts
S0/0/0 172.16.254.1 255.255.255.252 BR1 S0/0/0
S0/0/1 172.16.254.5 255.255.255.252 BR2 S0/0/1
BR1 G0/0 172.16.240.1 255.255.248.0 LAN de 2000 hosts
G0/1 172.16.224.1 255.255.240.0 LAN de 4000 hosts
S0/0/0 172.16.254.2 255.255.255.252 HQ S0/0/0
S0/0/1 172.16.254.9 255.255.255.252 BR2 S0/0/0
BR2 G0/0 172.16.252.1 255.255.254.0 LAN de 500 hosts
G0/1 172.16.248.1 255.255.252.0 LAN de 1000 hosts
S0/0/0 172.16.254.10 255.255.255.252 BR1 S0/0/1
S0/0/1 172.16.254.6 255.255.255.252 HQ S0/0/1

Parte 3: Cablear y configurar la red IPv4

En la parte 3, realizará el cableado de la topología de la red y configurará los tres routers mediante el esquema de direcciones VLSM que desarrolló en la parte 2.

Paso 1: Realizar el cableado de red tal como se muestra en la topología.

Paso 2: Configurar los parámetros básicos en cada router

a. Asigne el nombre de dispositivo al router.

b. Deshabilite la búsqueda DNS para evitar que el router intente traducir los comandos incorrectamente introducidos como si fueran nombres de host.

c. Asigne class como la contraseña encriptada de EXEC privilegiado.

d. Asigne cisco como la contraseña de consola y habilite el inicio de sesión.

e. Asigne cisco como la contraseña de VTY y habilite el inicio de sesión.

f. Encripte las contraseñas de texto no cifrado.

g. Cree un mensaje de aviso que advierta a todo el que acceda al dispositivo que el acceso no autorizado está prohibido.

Paso 3: Configurar las interfaces en cada router

a. Asigne una dirección IP y una máscara de subred a cada interfaz por medio de la tabla que completó en la parte 2.

b. Configure una descripción de la interfaz para cada interfaz.

c. Establezca la velocidad del reloj de todas las interfaces seriales DCE en 128000.

HQ(config-if)# clock rate 128000

d. Active las interfaces.

Paso 4: Guardar la configuración en todos los dispositivos

Paso 5: Probar la conectividad

a. En HQ, haga ping a la dirección de la interfaz S0/0/0 de BR1.

b. En HQ, haga ping a la dirección de la interfaz S0/0/1 de BR2.

c. En BR1, haga ping a la dirección de la interfaz S0/0/0 de BR2.

d. Si los pings no se realizaron correctamente, resuelva los problemas de conectividad.

Nota: los pings a las interfaces GigabitEthernet en otros routers no se realizarán correctamente. Las LAN definidas para las interfaces GigabitEthernet son simuladas. Dado que no hay dispositivos conectados a estas LAN, el estado será down/down (inactivo/inactivo). Debe haber un protocolo de enrutamiento implementado para que los otros dispositivos adviertan esas subredes. Las interfaces GigabitEthernet también deben tener un estado up/up (activo/activo) para que un protocolo de enrutamiento pueda agregar las subredes a la tabla de enrutamiento. Estas interfaces permanecerán en un estado down/down hasta que se conecte un dispositivo al otro extremo del cable de la interfaz Ethernet. Esta práctica de laboratorio se centra en VLSM y en la configuración de las interfaces.

Reflexión

¿Puede pensar en un atajo para calcular las direcciones de red de las subredes /30 consecutivas?
_______________________________________________________
Las respuestas pueden variar. Una red /30 tiene 4 espacios de dirección: la dirección de red, 2 direcciones de host y una dirección de broadcast. Otra técnica para obtener la próxima dirección de red /30 sería tomar la dirección de red /30 anterior y sumarle 4 al último octeto.

Tabla de resumen de interfaces del router

Resumen de interfaces del router
Modelo de router Interfaz Ethernet #1 Interfaz Ethernet #2 Interfaz serial #1 Interfaz serial #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Nota: para conocer la configuración del router, observe las interfaces a fin de identificar el tipo de router y cuántas interfaces tiene. No existe una forma eficaz de confeccionar una lista de todas las combinaciones de configuraciones para cada clase de router. En esta tabla, se incluyen los identificadores para las posibles combinaciones de interfaces Ethernet y seriales en el dispositivo. En esta tabla, no se incluye ningún otro tipo de interfaz, si bien puede hacer interfaces de otro tipo en un router determinado. La interfaz BRI ISDN es un ejemplo. La cadena entre paréntesis es la abreviatura legal que se puede utilizar en los comandos de Cisco IOS para representar la interfaz.

Configuraciones de dispositivos

Router BR1 (configuración final) 

BR1#sh run
Building configuration...

Current configuration : 1555 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname BR1
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description LAN with 2,000 hosts.
ip address 172.16.240.1 255.255.248.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
description LAN with 4,000 hosts.
ip address 172.16.224.1 255.255.240.0
duplex auto
speed auto
!
interface Serial0/0/0
description Connection to HQ S0/0/0.
ip address 172.16.254.2 255.255.255.252
clock rate 128000
!
interface Serial0/0/1
description Connection to BR2 S0/0/0.
ip address 172.16.254.9 255.255.255.252
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
banner motd ^C
Warning: Unauthorzed access is prohibited!
^C
!
line con 0
password 7 14141B180F0B
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 094F471A1A0A
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router HQ (configuración final)

HQ#sh run
Building configuration...

Current configuration : 1554 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname HQ
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description LAN with 16,000 hosts.
ip address 172.16.128.1 255.255.192.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
description LAN with 8,000 hosts.
ip address 172.16.192.1 255.255.224.0
duplex auto
speed auto
!
interface Serial0/0/0
description Connection to BR1 S0/0/0.
ip address 172.16.254.1 255.255.255.252
!
interface Serial0/0/1
description Connection to BR2 S0/0/1.
ip address 172.16.254.5 255.255.255.252
clock rate 128000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
banner motd ^C
Warning: Unauthorzed access is prohibited!
^C
!
line con 0
password 7 02050D480809
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 00071A150754
login
transport input all
!
scheduler allocate 20000 1000
!
end

Router BR2 (configuración final)

BR2#sh run
Building configuration...

Current configuration : 1593 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname BR2
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 10
!
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description LAN with 500 hosts.
ip address 172.16.252.1 255.255.254.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
description LAN with 1,000 hosts.
ip address 172.16.248.1 255.255.252.0
duplex auto
speed auto
!
interface Serial0/0/0
description Connection to BR1 S0/0/1.
ip address 172.16.254.10 255.255.255.252
clock rate 128000
!
interface Serial0/0/1
description Connection to HQ S0/0/1.
ip address 172.16.254.6 255.255.255.252
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
!
banner motd ^C
Warning: Unauthorzed access is prohibited!
^C
!
line con 0
password 7 070C285F4D06
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 0822455D0A16
login
transport input all
!
scheduler allocate 20000 1000
!
end
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
0
¿Tienes otra pregunta? Por favor comentax
()
x